Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to setup a virtual host. So far it's working on LAN but when I try to access it on another network, it's pointing me to my router's interface. I have PROLiNK H5004N ADSL2+ Wireless Modem/Router. I am not that familiar with port forwarding so I think this is the problem. Anyways, here's my configuration(Router Features>Virtual Server Forwarding):

ServerName:   WEB
Protocol: TCP
Local IP Address: 192.168.1.104
Local Port:   80-80
WAN IP Address:   my.ip.add.ress
WAN Port: 80-80

Here's my virtualhost config:

NameVirtualHost *:80
<VirtualHost *:80>
    DocumentRoot "C:\wamp\www\web"
    ServerName www.testweb.com
</VirtualHost>

Here's my hosts file:

127.0.0.1   localhost
my.ip.add.ress  www.testweb.com
share|improve this question

1 Answer 1

first always test with after any minor change with telnet command:

telnet yourpublicIP 80

if you get message connection timout you need to ckeck port forwarding.

on port forwarding configure always this way:

PROTOCOL:TCP
LOCAL IP:192.168.1.104
LOCAL PORT:80
REMOTE IP: any if options or leave blank.
REMOTE PORT:80

this is the basic parameters to enable port forwarding, just stay with the basics till work.

share|improve this answer
    
Thanks for the answer. I reconfigured my port forwarding to yours. I also added this line to my hosts file "my.ip.add.ress www.testweb.com". I tried accessing www.testweb.com through my browser and still no luck. It still points me to my router's interface instead of web server from 192.168.1.104. I'm going to check and test everything later. Thank you! –  nomonomo Jun 27 '13 at 2:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.