Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I finally got all my parts delivered to setup a home file/backup server this week.

It's currently running Ubuntu Server and I'm using Samba to share files on my network.

The server currently has a 2TB WD Green drive in it connected to a Asus M5A78L-M

This is then connected via CAT6a to my new Gigabit switch (TP-Link TL-SG1005D). My home desktop is then also connected to this switch and again also through CAT6a cable.

Currently when transfering files I will get a perfect 100MB/s read from the server to my Windows machine. When copying from my Windows machine to the server I get around 30/38MB/s.

I know this drive is capable is faster speeds so would anybody have an idea of where the bottleneck is?

Any help would be greatly appreciated :)

EDIT: I have found ftp's write speed is much closer to what my Samba read speed is so I'm going to give it a guess that is a software problem rather than hardware

share|improve this question
    
Are the drives in RAID? If so, what level? –  Darth Android Jun 27 '13 at 13:09
    
@DarthAndroid No not currently –  Ryan Holder Jun 27 '13 at 13:32
    
Have you tested locally on the server that the drives have better write speeds? dd if=/dev/urandom of=/mnt/disk/testfile bs=1M count=100 That should give you a good indication of disk write speed. It will see how long it takes to create a 100MB file. –  Darth Android Jun 27 '13 at 14:20
    
@DarthAndroid Yep I have tried that. Just connected with my brothers Windows 7 machine and the transfer speed is what would be expect yet on my Window 8 machine it is not. When I get a chance I will install Windows 7 on my machine to see if it is my NIC but seeing as ftp works fine I doubt it is that. –  Ryan Holder Jun 27 '13 at 15:56

2 Answers 2

As you edited in your post it sounds to me like a software issue. FTP will always be faster because FTP's goal is to be fast. Its a protocol meant for file transfer. My guess is that your connecting via LAN and thus using windows SMB protocol which is more for file sharing. Also windows will encrypt SMB transmissions which will significantly stagger your transfer speeds. I recommend just staying with an FTP transmission. If my theory is correct, you will see a similar issue in win7

share|improve this answer
    
That's the thing I have just tried connecting to the same share on my brothers Windows 7 machine and I get 100MB/s Write 100MB/s Read. On OS X I get 54MB/s Write 54MB/s Read. Really is strange. –  Ryan Holder Jun 27 '13 at 16:54
    
Its definitely not a hardware issue then and I am suspecting encryption. Refer to link a lot is going on behind the scenes that doesn't happen with FTP. –  Jason Bristol Jun 27 '13 at 16:59

Yes, the question before I start praising this HDD, which protocol you use to transfer files from Ubuntu?

WD Green slow HDD.

Among other things, constantly trying parking, from which the performance degrades even further. The site has a manufacturer firmware changes this behavior - of a parking lot at idle.

You can format a file system with a block size of 8K or 16K (better) - the speed will increase significantly. Yes, you'll pay for it some lost space.

Check the disk for errors and performance issues, perhaps you will be able to replace it under warranty. Green Series is very unreliable. And performance issues, as an option, the problem with the HDD.

share|improve this answer
    
I'm using SMB. And as for it being a write problem I have a 2 TB Green in my desktop and reading/writing from that drive is a constant 100MB/s+. –  Ryan Holder Jun 27 '13 at 12:00
    
@RyanHolder Copy a large enough set of files to another drive with HDD WD Green? To test the speed? If this is all right, the problem is in the SMB protocol, not a HDD. –  STTR Jun 27 '13 at 12:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.