Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In Windows 8 this switch was in PC settings near WiFi and mobile broadband switches. Now after updating to 8.1 Preview WiFi and mobile switches moved to the Network fly out panel (what is good, imho), but Bluetooth switch is not there for some reason. I've found separate Bluetooth section in PC settings -> PC & devices -> Bluetooth , but there are no actually switch to turn on/off the hardware, only to change visibility of the computer for other Bluetooth device.

Is there any place in Modern UI part of the Windows 8.1 where I could manage this setting (except for plain old classic Control Panel -> Network and Internet -> Network Connection -> "Disable Bluetooth Adapter")?

share|improve this question
add comment

4 Answers

up vote 1 down vote accepted

Well, it seems that luckily they have fixed this in RTM:

Screenshot with Windows 8.1 RTM Bluetooth settings

share|improve this answer
add comment
  • Go to the Desktop mode, open Libraries and go to Computer. Right-click on it, select Properties from the content menu and then click on Device Manager. You can also open Control Panel, click Hardware and Sound and then Device manager.
  • You will see the Bluetooth Radio Adapter is disabled, even the service is ON. Now right-click on it and enable the driver. When the icon appeares beside the clock, you are able to turn the Bluetooth on and off normally from Wireless setting.
share|improve this answer
    
That is interesting. However Device Manager show me that Bluetooth was already enabled and drivers are running fine. I tried to disable and enable it back, but that is not change anything as far as I could tell, unfortunately. Btw, I have this Bluetooth icon in the tray beside the clock and that, actually, how I noticed that Bluetooth hardware is on (and tryed to turn it off the old "Win 8" way). –  Sevenate Jun 27 '13 at 13:05
    
Could you please show some screen shot how this switch should looks like (from your machine with Win 8.1)? –  Sevenate Jun 27 '13 at 13:06
    
@Sevenate But i thought 8.1 is quite similar to 8.0, im planning to update as soon as possible, man. I'm sorry for i'm not able to produce a screenshot for you... Feel free to punish me, i will delete this comment. –  Arekkusandaa.Irujasukin Jun 27 '13 at 13:55
1  
No worries. Hovewer 8.1 is not quite similar to 8.0 - that is why I'm asking this. In 8.0 it was strait forward thing. –  Sevenate Jun 27 '13 at 13:59
add comment

I was having the same problem. It's easy to fix. Right click your bluetooth icon beside the clock, select Ënable bluetooth function". Now you should have the bluetooth tab on "PC and Devices". Windows also automatically finds and installs your bluetooth device, since i just did it and am writting this with a bluetooth keyboard ;) hope that solves it, cheers.

share|improve this answer
    
Thanks, Miguel, but I have no Bluetooth icon beside the clock when the Bluetooth is disabled (from Device Manager). On the other side - when it enabled (again from Device Manager) - the switch in Metro UI is in place as expected. And when I turn it off again, but from Metro UI this time - it will disable the Bluetooth and hide it-self from the Metro UI. So, still a bit weird to me :( –  Sevenate Oct 19 '13 at 21:00
    
Ok, with today's update for Broadcom 2070 Bluetooth driver the Metro switch for turning on/off Bluetooth finally stay visible after it was switched OFF from UI so, the entire UI is now fully usable (for me) without Device Manager snap-in involved. Thanks Broadcom! –  Sevenate Dec 25 '13 at 10:03
add comment

What you have to do is right click on the Bluetooth icon then click on show Bluetooth devices then the switch is displayed.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.