Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

OK so this has finally done my head enough to ask others if they have any idea what the issue may be.

Everytime I press the apostrophe key (or SHIFT + apostrophe to get an @ symbol) on my keyboard it takes around 2 seconds to actually print the character on screen (at which point a whole array of @@@@ symbols or apostrophes pop out unless I am quick enough to time it right and just get one). It's Almost like a sticky key, except sticky keys are turned off. Toggle keys are off as are filter keys.

Everything was fine until one random day it happened, I haven't changed any settings in Ease of Access center.

I have a Logitech G15 - Drivers all up to date, on Win 7.

One other interesting point is that when using RDP the key works just fine on the remote machine!

Has anybody ever encountered anything like this before?

Many thanks,

EDIT

I changed my keyboard input language to US and now my @ symbol works in Chrome, Visual Studio. But not in notepad, when pressing SHIFT + ' (apostrophe) key in notepad I get a: " (quote). I'm now all sorts of confused!

share|improve this question
3  
<kbd>Shift</kbd>+<kbd>'</kbd> is suppose to generate " –  Ramhound Jun 27 '13 at 14:55
    
@Ramhound At least, with a US keyboard. If Leigh doesn't have a US keyboard, then a Shift+' doesn't generate a ". What country did you buy your keyboard in, Leigh? –  Darth Android Jun 27 '13 at 15:05
    
I bought it in the UK, but the layout of the keys is a US layout @DarthAndroid. In other words my @ symbol is on the 2 key. –  Leigh Jun 27 '13 at 15:09
    
What is Shift+' supposed to type on your keyboard? You're correct that having @ on 2 would suggest it's a US layout and not a UK layout, but the US layout should also have " on ' –  Darth Android Jun 27 '13 at 15:12
    
Shift+' is supposed to produce an @ symbol (even though the ' key has a " printed on it as you suggest) - Oddly enough I have now changed my keyboard settings back to UK and it now seems to be OK. This has been bugging me for months, and I honestly don't know what the solution was. –  Leigh Jul 1 '13 at 19:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.