Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed Ubuntu (ubuntu-13.04-desktop-amd64) on a 8 gb pendrive. Because it worked pretty slow, I wanted to change it back to a normal pendrive. But this is what happened.

Windows7 can't open the usb drive, can't view files or anything, can't access attributes. When I select to format, it says it can't format it because it is write-protected. Tried the same running from an Ubuntu, and trying from a booted GParted thing. When I view the partitions, they can't be deleted either.

What should I do to get it formatted?

share|improve this question
    
More information on whats preventing you from it working in GParted is required. Not being able to format a Linux partition on a drive is normal Windows does not support them. – Ramhound Jun 27 '13 at 22:24
    
It also says the drive is write-protected. Can't modifie anything with it really. – weiszam Jun 27 '13 at 22:27
    
There are ways to ignore the write protection. There are lots of tutorials on the subject. – Ramhound Jun 27 '13 at 22:32
    
Could you send me some links? I've searched a lot for ways, tried a lot of things.. – weiszam Jun 27 '13 at 22:37
    
I found this by doing a single search, it was the very first result, funny how that works. askubuntu.com/questions/217571/… was the solution and here is the Google search google.com/… – Ramhound Jun 28 '13 at 0:08

Optionally if gparted can't delete the partitions, you could use dd to clear the device.

Type sudo bash in the terminal of gparted.

Type in dd if=/dev/zero of=/dev/sda bs=4k conv=notrunc

And replace sda with whatever the gparted software shows it as being, sdb, sdf, sdz, etc.

share|improve this answer
    
Okay formatting a lot of times and stuff got me there that I can now use it, but it's still read-only. Can't delete files, but can create new ones. The response tp this dd command you gave me is dd: 'dev/sdd': Read-only something. What to do now? – weiszam Jun 28 '13 at 9:37
    
Try this command. sudo umount /dev/sdb And then sudo fsck.vfat -f -v /dev/sdb Of course replacing sdb with whatever gparted displays. – user88311 Jun 28 '13 at 16:24
    
Here's the console text in: sudo umount /dev/sdc out: /dev/sdc: not mounted in: fsck.vfat -f -v /dev/sdc out: dosfsck 3.0.16 (01 Mar 2013) dosfsck 3.0.16 01 Mar 2013, FAT32, LFN Currently, only 1 or 2 Fats are supported, not 251. What do do now? – weiszam Jun 28 '13 at 21:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .