Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running vim on Windows and I'm using an US keyboard layout with deadkeys. When pressing ~ + a, I get a as output (instead of ã).

Other info:

  • ~ + a produces the desired ã on gVim.
  • ~ + a produces the desired ã on Windows command prompt (outside of vim)
  • ~ + a is, in fact, producing an a on vim; it's not just a matter of displaying it the wrong way. For instance if I :imap a b I get a b when pressing either a or ~ + a.
  • Other accents produced with deadkeys work as á, à, etc.
  • ã or õ don't even show up when typing dig:

   A` A  192  A^ A  194  A~ A
   I" I  207  N~ Ñ  209  O` O
   a^ â  226  a~ a  227  a" ä
   o` ò  242  o^ ô  244  o~ o
  • When copying ã and pasting into vim, I also get an a. If I save the file and open with other editor, vim actually writed an ã.
share|improve this question
    
In vim to enter special characters, I have to type <kbd>Ctrl+K</kbd> and then type the special sequence (i.e. ~+n or :+o). Then it is inserted, though I don't use an international keyboard. –  nerdwaller Jun 27 '13 at 22:49
    
Yes, ã could also be inputed by pressing Ctrl+K, a, ~ but that also produces a a. I updated the question with (part of) my output to :dig (which shows vim's digraphs) –  VImProblem Jun 27 '13 at 23:56
    
What's the encoding in vim? Is it using an 8-bit character set instead of utf8? Are there any other characters that look wrong in the digraph list? –  Bradd Szonye Jun 29 '13 at 0:18
    
I get: fileenconding="", fileencondings=utf8 and set enconding returns unknown option. There are other characters looking wrong, you can see some of them of my dig output like: Ã, Ò, õ, Â,À, but somewhat strangely â, ô, á, ó, ç look ok –  VImProblem Jun 29 '13 at 14:14
add comment

1 Answer 1

The only workaround I found consists on using mintty (the mintty version of vim can be installed using mingw-get.exe). As a plus you get a resizable terminal with more confortable copy-and-paste, fullscreen, etc, etc.

share|improve this answer
    
Is this all on your local windows machine? or are you ssh'ing into another machine? ssh can grab the tilde if configured to use it as an escape character. The only other thing that comes to mind concerns your plugins. Very odd that the mintty version works though. What terminal were you using? –  lornix Jul 22 '13 at 13:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.