Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

enter image description here enter image description here

My Linksys WRT54GS2 V1 has begun to display ghost wired connections in the last weeks. As you can see from the images I have nothing connected except for the power cable.

I have tried a hard reset and factory defaults, also leaving the router disconnected all night.

The DHCP list show no clients but the one I'm connecting from.

The problem this causes is limited connectivity for Wireless devices and no connection at all for wired connections. Only my wireless laptop can connect always, and a wired connection can connect sometimes.

After setting a mobile wifi configuration to static instead of DHCP, I managed to be able to connect that device. So I guess there's a problem with the DHCP of the router.

share|improve this question
    
Maybe a drop of solder on one of the connectors? Have you tried opening it up and looking at the pins? –  Gallefray Jun 27 '13 at 23:04
    
No I didn't try anything at hardware level. The router didn't fall or anything like that, so I was hoping for a software solution. –  Veehmot Jun 27 '13 at 23:15
    
Huh. Faulty firmware? If it doesn't void your warranty, I'd open it up and see if there's a stray dollop of solder or something. Has it always been like this? –  Gallefray Jun 27 '13 at 23:27
    
No, like I said it has been like this in the last weeks. I have this router for like 2 years now. –  Veehmot Jun 27 '13 at 23:49
2  
Link indicators are not affected by DHCP, but electrical polarity. Examine the ports carefully; a wire might have jumped its slot, creating a 'loopback' condition. I notice you have a universal power supply: If you've been running the router below its required voltage and amperage, it may have malfunctioned, possibly permanently. –  Nevin Williams Jun 28 '13 at 5:35
show 1 more comment

1 Answer

Since the hardware is out of warranty I suggest trying a different firmware, if the problem still exists, then its a hardware level problem and cannot be solved by software.

There are two additional files on the firmware database at http://dd-wrt.com so be sure to search for your router for more information.

share|improve this answer
    
Thanks for the answer. I have already downloaded DD WRT packages for my router but, as it is an irreversible change, before trying that I was hoping for a less drastic solution. Do you believe this kind of problem can be solved by changing the firmware? –  Veehmot Jun 28 '13 at 0:24
1  
@Veehmot - Based on the description you provided the current status of your router is that its pretty useless. Since I can guarantee that DD-WRT is better then the stock firmware you have, what you have to lose is, what basically amounts to a broken router. Please don't tell me this router is from 2003 because it doesn't even support 802.11n. –  Ramhound Jun 28 '13 at 0:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.