Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying Windows Azure, and would like to see if I can connect from Windows Xp / Vista...

The error message that I get when trying to connect from Xp:

Remote Desktop cannot connect to the remote computer because the authentication certificate recieved from the remote computer is expired or invalid.
In some cases, this error might also be caused by a large time disrepancy between cliend and server computers.

Here they tell that version 7 of RDC should make it working: http://community.spiceworks.com/topic/299307-rdp-from-xp-embedded-to-windows-server-2012 . I have upgraded the RDC to version 7 but still it won't work. In my Remote Desktop Connection about screen (by right clicking on the window's title) I see this:

Shell Version 6.1.7600
Control Version 6.1.7600
c 2007 Microsoft Corporation. All rights reserved.
Network Level Authentication supported.
Remote Desktop Protocol 7.0 supported.

I have found out that on Windows Server 2008 it was necessary to configure network level authentication for Remote Desktop Services Connections (http://technet.microsoft.com/en-us/library/cc732713.aspx).

In My Computer properties, Remote Settings at Remote tab I have the combobox on Allow remote connections to this computer and tried the checkbox below with unchecked and checked state for Allow connections only from computers running Remote Desktop with Network Level Authentication recommanded (recommended)

I tried to Google this issue, but no solutions so far.

If you have figured it out somehow, share please! Thanks!

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

In some cases, this error might also be caused by a large time discrepancy between client and server computers.

Make sure the time on your XP machine is correct. If it's set to the year 2020 it would appear that a certificate that expires in the year 2019 has expired.

Alternatively, one thing I find customers neglect to do when they upgrade to RDC 7 and later is to enable CredSSP at the same time.

Why the RDC installer doesn't do this itself is a mystery to me, but at least the KB article has a *fix it for * utility.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.