Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Ok, so I know that this question has been asked a million times, but it seems that using the solutions from questions like this has not helped me so far.

How do I set default permissions for new files uploaded through vsftpd?

As of now the files will get the following permissions:

-rw-r--r-- 1 pi   pi      7 Jun 28 13:21 FILENAME

But I need the file to be executable. I could manually chmod the files, but that would not include files in the future. What i have tried:

  1. Setting umask in login.defs - Even after a restart, if I then type umask I will get umask 0022 (not what I set)
  2. Setting local_umask=022 and file_open_mode=0644 in /etc/vsftpd.conf

Does anyone have a solution for this? The permissions for future files should be somewhat like:

-rwxr--r--

Hope you understand. I'm new on linux.

share|improve this question
    
possible duplicate of default file permissions for ftp uploads in ubuntu (vsftpd) –  techie007 Jun 28 '13 at 13:40
    
Did you restart the vsftpd daemon after you changed the configuration file? –  druciferre Jun 28 '13 at 13:52
    
Yes, even tried a reboot. –  Richard Jun 28 '13 at 14:00
    
Umm…, you tried setting file_open_mode=0644? Why not 0744, which is what you want? –  Scott Jun 28 '13 at 16:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.