Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running NAT on an ubuntu host machine to linux guests. The vmnet8 address is getting Destination Host Unreachable when pinging from the host machine itself.

steve@hostmachine:/shared$ ifconfig -a

  ...    
vmnet1    Link encap:Ethernet  HWaddr 00:50:56:c0:00:01  
          inet addr:172.16.141.1  Bcast:172.16.141.255  Mask:255.255.255.0
          inet6 addr: fe80::250:56ff:fec0:1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:99 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

**vmnet8**    Link encap:Ethernet  HWaddr 00:50:56:c0:00:08  
          inet addr:**192.168.238.1**  Bcast:192.168.238.255  Mask:255.255.255.0
          inet6 addr: fe80::250:56ff:fec0:8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:14636 errors:0 dropped:0 overruns:0 frame:0
          TX packets:81362 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

I am seeing intermittent "host unreachable" errors on the host just pinging the VMNET8 interface.

steve@hostmachine:/shared$ ping 192.168.238.130
PING 192.168.238.130 (192.168.238.130) 56(84) bytes of data.
From 192.168.238.1 icmp_seq=1 Destination Host Unreachable
From 192.168.238.1 icmp_seq=2 Destination Host Unreachable
From 192.168.238.1 icmp_seq=5 Destination Host Unreachable
From 192.168.238.1 icmp_seq=6 Destination Host Unreachable
From 192.168.238.1 icmp_seq=7 Destination Host Unreachable

Why would this happen? Any suggestions on how to fix this?

@september: (In response to inquiry): presently the error is not showing up (thus the 'intermittent' qualifier to this issue). But in any case here is output of netstat -rn

steve@mithril:/shared$ netstat -rn
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
0.0.0.0         10.101.204.1    0.0.0.0         UG        0 0          0 wlan0
10.101.204.0    0.0.0.0         255.255.252.0   U         0 0          0 wlan0
169.254.0.0     0.0.0.0         255.255.0.0     U         0 0          0 wlan0
172.16.141.0    0.0.0.0         255.255.255.0   U         0 0          0 vmnet1
192.168.238.0   0.0.0.0         255.255.255.0   U         0 0          0 vmnet8
share|improve this question
    
Please provide output of netstat -rn – september Jun 28 '13 at 15:39
    
i added it above – javadba Jun 30 '13 at 19:46
up vote 0 down vote accepted

You have incorrect (default) gateway 10.101.204.1 for subnet 192.168.238.0 on mithril. It is possible reason for problem. Try to add correct (192.168.238.1):

route add -net 192.168.238.0 netmask 255.255.255.0 gw 192.168.238.1

or

route add -net 192.168.238.0 netmask 255.255.255.0 gw 192.168.238.1 dev vmnet8

Also recheck default gateway on host mashine with netstat -rn

More about Linux "route" command.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .