Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Have a Java Swing app that is running on a Linux server and is being X displayed back via X11 forwarding. Cygwin is running on my workstation. Connection is made to the server using PuTTY with X11 forwarding and then ssh -XY .

Application launches just fine, but certain GUI elements (mostly drop down menus) do not behave correctly. Some menus close immediately after they are opened (the blink open/close when clicked.) Others will not select / highlight items using the mouse. Others will select different items than the one hovered over by my house.

The application works just fine on Windows or on Linux when invoked directed. Problem seems specifically related to viewing it through X11.

Is it possible X11 is swallow some GUI events or not repainting fast enough?

share|improve this question
    
Having a similar problem, and noticed that the mouse location and the app's responding click point seem to slowly drift out of sync over time with use. (e.g. open and close menus and wiggle the mouse, and progressively things get worse) –  Walt Stoneburner Jun 28 '13 at 16:34

1 Answer 1

up vote 1 down vote accepted

I have noticed that some applications really do not like the X-forwarding done by ssh. In such cases I have had to resort to setting the real IP number in the DISPLAY variable to get the windows back to the designated host properly.

Also, make sure you have opened the permissions to allow windows to be displayed on the remote host....by executing the command 'xhost' (see man page) on the host that you want to receive pages, hopefully listing all the hosts that are allowed to send pages. NOT RECOMMENDED: in a pinch I use xhost + which opens the display to all IPs.

share|improve this answer
    
That worked very well. Thank you! –  marlhammer Jul 1 '13 at 18:59
    
Concur -- that solved my problem as well. Curious to know what's actually happening under the hood that's resolves the issue. –  Walt Stoneburner Jul 1 '13 at 19:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.