Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I added a file type using the ftype command. Now I want to add another ftype for use with the Open With context menu.

Is this possible? If so, how? If not, is there another way to do it?

share|improve this question

2 Answers 2

Use a text editor and copy the contents below:

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\*\shell\Open with Notepad]

[HKEY_CLASSES_ROOT\*\shell\Open with Notepad\command]
@="notepad.exe %1"

Change the contents as necessary and save as a .reg file.

Double click the .reg file and accept any UAC prompts. The new entry will now be in the context menu.

share|improve this answer
    
So you're saying it's NOT possible with ftype. –  Adrian Jun 28 '13 at 19:09
    
dont know. just giving you another way. –  Keltari Jun 28 '13 at 19:28
    
@Keltari: Don't use blockquote or >, use pre or code instead (indent by 4 spaces). The former messes with backslashes as you can see in your original answer. Especially important with something like a .REG file. You don't want to be held responsible for messing someone's registry! –  Karan Jun 29 '13 at 1:58
    
@Adrian: No, what you want isn't possible to achieve using ftype. Also note that Keltari's .REG file above will add the Open with Notepad command to all file types. If you want to add for only, say .TXT, you need to navigate to HKEY_CLASSES_ROOT\.txt, find out the ProgID i.e. txtfile, then go to HKEY_CLASSES_ROOT\txtfile\shell. –  Karan Jun 29 '13 at 2:01

Whenever a filetype opens in default in Microsoft Notepad for example, I rightclick and choose Open With...

From there I browse, choose my program once I find it, and then once I do that one time it appears the next tme I right click and choose Open With...

So you do have to manually do find the program the first time per filetype, but after that it should appear automatically under Open With...

share|improve this answer
    
Doesn't work for calling programmes using a specific command line layout. I.e. a command that doesn't accept the file name as the last command line parameter. –  Adrian Jun 28 '13 at 19:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.