Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a USB 2.0, 500 GB HDD. I am writing a bunch of data to it, that I previously recovered from the drive.

I have formatted the drive in exFAT, since the drive will be used with Windows and OSX.

At first, I tried using Windows explorer to move the files over to the drive (about 160 GiB worth) but after copying about 30% of the data (according to TeraCopy), Windows Explorer reported the drive as out of space, and that it was completely full.

WinDirStat only showed the size of data that had been copied over... Where did this extra space go? Why is there a 300+ GiB discrepancy between the usage reported by the files and what Explorer sees?

share|improve this question
1  
I believe that I solved this, but I wanted to post for posterity: I had changed the allocation size to 4096 kilobytes when formatting the disk. I believe the default for a 500 GB is 128 kB. –  steve Jun 28 '13 at 19:54
    
you sure you didn't just partition improperly? And I am confused on what you're saying there. Also if you have fixed this you can "answer your own question" –  Griffin Jun 28 '13 at 20:59
    
@Griffin I think he's saying that he used a large allocation size, and with a lot of small files you will waste a lot of space on disk by doing that. (i.e., all files less than 4KiB will still consume at minimum 4KiB). (Also, I declined your use because 'GiB' is valid - it's 1024^3 bytes, as opposed to 'GB' which is 1000^3 bytes. Just gotta depend on the author for knowing what he's using.) –  Darth Android Jun 28 '13 at 21:45
    
@DarthAndroid I like consistency, they aren't consistent. –  Griffin Jul 7 '13 at 6:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.