Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have ATI Mobility Radeon HD 5470 on my HP laptop. A few weeks ago I was confused with a weird trouble in proprietary drivers for my graphics card. When I start X server (or just boot Windows) system sometimes totally hangs up with black screen. The most annoying thing is that issue appearing is absolutely random (2 success, 3 fails, 1 success, 7 fails, etc.). It appears both on Linux (Arch, Debian 7) and Windows XP. I've tried reinstalling OS, drivers, etc. I've also tried updating BIOS. Then boot was successful for the next few times and issue appeared again (probably it was just a coincidence, because another BIOS updates gave no results). I really don't know what to do. Any ideas?

share|improve this question
1  
Sounds like hardware failure. –  Ramhound Jun 28 '13 at 22:29
    
is it possible your trying to attribute it to the video , video card and driver, when it could be something else? Like a memory setting, or a PCI(&E) clock rate setting , or other possible hardware things. Being less likely that it is software things when having the same problem in both systems. Does the bios allow for any changes to be made to such settings? With SOME laptops it could even be related to the quality of the battery, when the battery provides suplimental power in high power use times. –  Psycogeek Jun 29 '13 at 7:32
    
Are all the fans spinning up normally, is the air flow good still, is it possible that it is in dire need of cleaning? is it possible that the thermal paste might be a dried up hunk of uselessness :-) –  Psycogeek Jun 29 '13 at 7:39
    
Yes, I also think this is some kind of hardware failure or BIOS. But since I did not make any changes in BIOS, it is quite likely, that this is still something in hardware. I've tried before to turn it on without battery, but uselessly. I also disassembled laptop and cleaned up everything I can get. –  Oleg Jun 30 '13 at 8:06
    
Well, I understand that there is no nice way to fix it alone (I am software engineer, not hardware). But maybe there is some kind of workaround? Please post it, if you know. Also, that's what I found in X.org.log: [ 36.974] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:17:0) found [ 36.974] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:18:0) found < like this about 10 times > –  Oleg Jun 30 '13 at 8:16

1 Answer 1

up vote 0 down vote accepted

Well, the workaround I've found for that issue was to hibernate laptop instead of shutting down. After few months laptop stopped booting at all (black screen after pressing button and nothing else). Then I've figured out, that my AMD chipset is dead. I replaced it, and it helped.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.