Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So here is the situation. I find myself technological knowledgeable about many things ( I love to code, whether it's websites, C#, C++ or so on). However:

My 2 toddlers (my wife actually) bought me a "Generic" 128 GB USB Storage Device (Usb Flash Drive) for Father's Day. I thought awesome at first..... WRONG! Nothing but problems with it. 3-4mb/s MAX transfer speed.

I can bear with it.

BUT!

When I went to reformat my computer I transferred my save files from my games over to the stick and then the USB Stick managed to become corrupted. Not just a simple format would work either. It's screwed.

I tried to use (Manually changed usb drive letter troubleshooting it to X) chmod X: /X /F /R with administrator rights, I did this after a long session to make it work with no errors (had to delete the log) and I finally recovered the files, however when I go to use it (transfer to or from) it transfers a couple kb to the stick or from it and then freezes, It says (Windows 7):

Name:
From: Folder (X:\File\Location)
To: Folder C:\Users\Username\Desktop)

Items Remaining: 0 (0 bytes)
Speed: 0 bytes/second

It does this forever... and ever... and ever... It transfered 3 files atleast, and then stopped.

This is a new USB Stick bought from a "High" reputation company on eBay.

Is the USB Stick screwed?

share|improve this question
    
Throw it at H2testw. It's a tool designed to detect fake flash drives. Fake flash drives fake the capacity displayed to the user, which typically results in data loss. There's dozens of blogs listing known bad sellers, detection methods and some partial salvage methods. –  Bob Jun 29 '13 at 20:51
    
Nope I used h2testw but I couldn't click anything else as soon as I chose the "target" X: –  Jesse J. Jun 29 '13 at 21:08
    
Question, have you tried transferring the data with a live linux distro. –  user88311 Jun 29 '13 at 21:16
    
Sounds like a fake –  warsong Jun 29 '13 at 21:55
    
I don't have Linux :/ –  Jesse J. Jun 30 '13 at 13:52
show 2 more comments

1 Answer

up vote 1 down vote accepted

Sounds like you could have a fake drive. In reality is much smaller drive but was flashed to report 128GB. This video shows an example of such a drive https://www.youtube.com/watch?v=HaHokQ5EWv0

To be sure of this fact, consider using tools such as H2testw or BurnInTest to verify this device's capacity. It will try to write and read data to the full capacity of the device and report how accurate it is. H2testw screenshot of 4GB drive pretending to be 64GB

For Linux and Mac there's http://oss.digirati.com.br/f3/ that does the same thing.

If your device turns out to be fake, report it as 'counterfeit goods' to Ebay and leave negative review to the seller to inform others not to buy this product and to entice the seller to correct this problem either by refunding you money or providing you with a properly functioning drive. However, do not remove your negative review in exchange for a refund or new drive. It is blackmail(and I'm pretty sure against ebay TOS).

share|improve this answer
    
Well this didn't fix it, I guess it's just totally broken. It must be a fake, never have I heard of that yet haha oh well. –  Jesse J. Jun 30 '13 at 13:51
    
@JesseJ. I updated my answer above. –  Mxx Jun 30 '13 at 19:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.