Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How can I fix this problem?

I ran the tests ./test-raindrop.py and all failed with the same error:

    Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/twisted/internet/defer.py", line 751, in _inlineCallbacks
    result = g.send(result)
  File "/home/stuartcw/Documents/Code/raindrop/server/python/raindrop/model.py", line 434, in _do_update_views
    _ = yield self.open_view(did, vn, limit=0)
  File "/home/stuartcw/Documents/Code/raindrop/server/python/raindrop/model.py", line 117, in open_view
    return self.db.openView(docId, viewId, *args, **kwargs)
  File "/home/stuartcw/Documents/Code/raindrop/server/python/raindrop/wetpaisley.py", line 111, in openView
    return requester(uri, *xtra
  File "/usr/local/lib/python2.6/dist-packages/paisley-0.1-py2.6.egg/paisley.py", line 286, in get
    return self._getPage(uri, method="GET")
  File "/home/stuartcw/Documents/Code/raindrop/server/python/raindrop/wetpaisley.py", line 74, in _getPage
    factory = HTTPClientFactory(url, **kwargs)
  File "/usr/lib/python2.6/dist-packages/twisted/web/client.py", line 258, in __init__
    self.setURL(url)
  File "/usr/lib/python2.6/dist-packages/twisted/web/client.py", line 269, in setURL
    scheme, host, port, path = _parse(url)
  File "/usr/lib/python2.6/dist-packages/twisted/web/client.py", line 415, in _parse
    parsed = http.urlparse(url)
  File "/usr/lib/python2.6/dist-packages/twisted/web/http.py", line 183, in urlparse
    raise TypeError("url must be str, not unicode")
exceptions.TypeError: url must be str, not unicode

Any help appreciated

share|improve this question
2  
May I suggest that you report this problem directly to Mozilla? I've looked around, I'm not sure, but I think this is the Tracker of the Project: getsatisfaction.com/mozilla_messaging/products/mozilla_raindrop – Bobby Oct 27 '09 at 13:49
    
Raindrop is still under development, there is no stable version even. As such, you should see indeed with Mozilla directly for any problem, like Bobby suggested. A problem on a version in early stage of development is most likely to be fixed on their side, not yours. – Gnoupi Oct 27 '09 at 14:58
    
Yes is it is in development. I had to install both Erlang and CouchDB from source before I could get to the error above. Actually, I read in the RainDrop docs that the team were accepting questions on StackOverflow and I noticed that a question about Raindrop had been forwarded over to here. Thanks very much to tayfun for his helpful comment below.. – Stuart Woodward Oct 28 '09 at 9:55
up vote 1 down vote accepted

This has already been fixed. See the discussion at getsatisfaction: http://getsatisfaction.com/mozilla_messaging/topics/twisted_errors_on_run_raindrop_py

You basically need to update your raindrop codebase. If you installed using mercurial, change into the root directory of source code and do a "hg pull" followed by an "hg update". That should fix it.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .