Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am on Windows 7 x64, trying to install Python 2.7.5 or 3.3.2. But I'm continuously getting an error showing : "There is a Problem with this windows installer package. A DLL required for this install to complete could not be run. Contact your package vendor. "

I have freshly downloaded the installer package from Python.org for several times but it is giving the same error repeatedly. Please help !

I am also attaching a picture of the error message as it appears while installing.enter image description here

Thank you for your kind concern.!

share|improve this question

migrated from stackoverflow.com Jun 30 '13 at 12:58

This question came from our site for professional and enthusiast programmers.

    
Yes !!! that did work good.. Thank you very much for this info. but it led me into another Question that why am I not being able to access the installer as administrator while I am logging in as an administrator ? I don't understand ! – abhisek Jun 30 '13 at 9:05
up vote 4 down vote accepted

I think this might work:

  • Go to C:/Users/XXX/AppData/Local/Temp or simply %LocalAppData%/Temp.
  • Go to Properties.
  • Change permission level for everyone to FULL ACCESS.
share|improve this answer
    
ya! it worked for me. But can you explain why does that happened. I am logged in as the administrator but still why ? – abhisek Jun 30 '13 at 9:19
    
Maybe the installer doesn't have the right privileges? Mind you, the privilege system in Windows is really weird. – Farid Jun 30 '13 at 9:41
    
yah! i agree too... @Farid – abhisek Jun 30 '13 at 12:32
1  
This didn't work for me though the symptoms were similar. Turned out to be a conflicting PIP install. This fixed me: stackoverflow.com/a/23350061/797945 – Jagu Dec 16 '14 at 10:21
    
Note that "%temp%" is a shortcut to that location. – phk Nov 17 '15 at 11:41
  • Run cmd.exe (run as administrator)

  • Go to Python's location (example: D:\python\) by changing the directory

  • Write msiexec /i filename.msi, e.g. msiexec /i python-3.4.1.amd64.msi

  • Then Enter

share|improve this answer

I was just trying to install 32 bit version on x64. Tried again with correct version and problem solved.

share|improve this answer
2  
Can you please provide more details. One line answer do not count as good one. – Romeo Ninov Mar 7 at 6:51

I had extraneous Python environment variables from previous installations. You should delete any Python environment variables and retry.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .