Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have found this problem a couple of times. Windows 7 with Intel AGN 5100 won't connect to a WPA2-PSK router when it's too far away.

Both times I've had this happen I was in a foreign country (London and Stockholm), and both times I was upstairs while the router was downstairs.

Now, it still has 2-3 bars when looking at local WiFi, but I get the "will not connect" error, and debugging doesn't help at all (it doesn't know what's wrong). I went downstairs and it connected immediately (but I need to be able to have it upstairs).

My Android Cell Phone and iPad were able to connect upstairs just fine.

Any suggestions?

share|improve this question
1  
Get a better wireless adapter –  Ramhound Jun 30 '13 at 19:45
    
^ Ramhound -- that worked. –  Kerry Jul 1 '13 at 20:00

2 Answers 2

up vote 1 down vote accepted

The best solution would be to buy a better Wireless Router or add a cheap Repeater or buy a better Antenna. Check if you have an older wireless router ( 802.11b, 802.11g), consider replacing it with a newer wireless 802.11n or 802.11ac device that offers longer ranges and faster connection speeds. You could also try to set your iPad/Smartphone as Wireless Ad-Hoc Network/Second Access Point and then connect your laptop or PC to that device, that would widen the range of your wireless network. Also try to change your wireless channel, update your firmware or your network adapter driver, reposition better your Router in the house. You could try also to widen the range with home made Aluminium Foil, click here.

share|improve this answer
    
I bought a new wireless network adapter -- I am staying in someone elses home, so I can't change their settings. It seems to be working fine. –  Kerry Jul 1 '13 at 20:00

The solution was to buy a new Wireless Network Adapter (I bought a Jensen Scandinavia USB Stick), and it worked well. I marked Devid's answer as the accepted answer because he had a plethora of good ideas, though unfortunately they weren't the answer for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.