Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a fresh install of Mint 15 with Cinnamon and I can't find an option to hide all icons on the desktop. In settings->Desktop there are only options to show/hide the home folder, trash, etc, but no option to hide the contents of the "Desktop" folder.

How do I hide the $HOME folder contents from appearing on the desktop in Linux Mint 15?

UPDATE:

It actually looks like the icons on the desktop are the contents of the $HOME folder, not $HOME/Desktop.

** Question was edited to reflect the fact that it was the user's home folder icons showing, not just "my computer", "trash", etc.

share|improve this question

3 Answers 3

Cinnamon uses nemo to draw the desktop. One way of removing the icons would be to stop nemo from loading. Go to "Cinnamon Settings" => "Startup Programs" and deselect "Nemo" from the list of startup programs.

Alternatively, to select which icons you want to show, go to "Cinnamon Settings" => "Desktop" (this is from my Cinnamon 1.8.2):

enter image description here

share|improve this answer
    
I've been to the desktop icons setting window before, but the problem is, it's showing all of the files and folders in my home folder (not Desktop folder) right on the desktop. Isn't nemo also the file manager? Don't I need that to browse files/folders? –  N Rahl Jul 1 '13 at 15:01
    
@NRahl yes, nemo is the file manager. If you use it to browse, that will make the desktop appear (sorry, I never use the file manager, I do verything from the command line so it did not occur to me). If it showing the contents of your $HOME, there is something else going on, I would recommend posting a different question or editing this one to ask about that only. –  terdon Jul 1 '13 at 15:03
    
I've updated the question. –  N Rahl Jul 1 '13 at 15:09

I had the same problem and the following command solved it:

gsettings set org.nemo.preferences desktop-is-home-dir false

The related issue on github is here.

share|improve this answer
    
I think this is the real solution. +1 for the github link –  Kwaio Aug 23 '13 at 8:21

Cinnamon Desktop environment used to provide option to hide desktop icons, but I believe that option is no longer available since version 1.6.
If you can get to install a previous version of cinnamon you might be still able to do that

share|improve this answer
    
If they removed it... is there another way to do it? I don't see why they would remove a feature, unless it was replaced by something functionally equivalent. –  N Rahl Jul 1 '13 at 0:08
1  
@NRahl Use dconf editor Go to org-gnome-desktop-background and tick "Show desktop icons" - I picked this up from an ubuntu forum, and since I am on a windows machine right now, I can't test it.If it helps you do let me know , I will append it to my answer –  Shakehar Jul 1 '13 at 14:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.