Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For a test purpose, I would like to increase the default tcp timeout to say 2 mins. I tried this: How to set TCP/IP abort interval or timeout in Windows XP?

http://support.microsoft.com/kb/170359

and set TCPInitialRtt t0 0x10

But I still have 21 seconds timeout.

I am using Windows 7.

Qns:

  1. Should I reboot windows after changing the registry (I already did before trying though)
share|improve this question
2  
I would expect any change like this to require a reboot. –  uSlackr Jul 1 '13 at 15:26
add comment

2 Answers

up vote 0 down vote accepted

Are you sure you specified the correct timing? The link you posted says the key is configured as follows:

Value Name:  TCPInitialRtt
Data Type:   REG_DWORD
Valid Range: 300-65535 (milliseconds in decimal)
Default:     0xBB8 (3000 milliseconds expressed in hexadecimal)

So, if you wanted a 2 minute timeout, your hex value should be 0x1D4C0 or 120000 milliseconds. But that's not a valid range according to MS... So you'll have to decrease the length of the timeout...

share|improve this answer
    
Yup, it’s in milliseconds, so I can’t figure out why 0x10 (16) was used if two minutes is desired (16 milliseconds is not even a valid value because the minimum is 300; so it is likely reverting to the default of 3000 ms or three seconds—the reason that the OP is still seeing 21 seconds instead of the default 3 is because the driver is still using the old value). And yes, the maximum supported timeout is a little over one minute (though the retransmit limit is 0xffffffff which if the timeout supported, would be equal to 49 days). –  Synetech Jul 1 '13 at 16:16
add comment

Yes, that change almost certainly requires rebooting for it to take effect (as do most system-level changes).

If you simply cannot reboot at the moment, but still want to force the change, you can attempt to restart the appropriate services and drivers, however that may be difficult or even impossible due to dependencies and restrictions.

If you want to try it (be wary that you might end up crashing the system by doing so, which would put you right back at rebooting), you can use the Device Manager:

  1. Open the Device Manager (Start ⇨ devmgmt.msc)
  2. Enable hidden devices (View ⇨ Show hidden devices)
  3. Expand the Non-Plug and Play Drivers branch
  4. Open the Properties dialog for TCP/IP Protocol Driver
  5. Select the Driver tab and click [Stop]
    • If you have no dependent services/drivers running, then it should stop and you can click [Start] to restart it
    • If you have dependent services/drivers running, it will prompt you to stop them (which may have other services/driver dependent on those)

If you restarted the TCP/IP Protocol Driver, then the service should be using the new settings, but there may still be other services/drivers that access that parameter, so you may still end up having to reboot (also, you can try disabling the network adapter under Control Panel ⇨ Networking to get it to propagate to the NIC’s driver).

share|improve this answer
    
Also, as Dallas said, your value is incorrect; it is expressed in milliseconds, and the limit is a little over one minute. –  Synetech Jul 1 '13 at 16:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.