Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Cygwin installed on Windows 7 in a windows domain sign-on environment. I can run most typical commands without issue, but I cannot for the life of me use the "mv" command to move or rename files, regardless of the file or directory.

I can copy and create files without issue.

┌─[12:27:57]─[mbutl2@MYHOSTNAME]
└──> tmp $ >> pwd
/tmp
┌─[12:27:58]─[mbutl2@MYHOSTNAME]
└──> tmp $ >> touch test.txt
┌─[12:28:02]─[mbutl2@MYHOSTNAME]
└──> tmp $ >> mv test.txt hello
-bash: /usr/bin/mv: Permission denied

I have already tried running Cygwin terminal as Administrator and the problem is the same.

I'm open to workarounds, such as trying another exe for moving files and redirecting the mv command to it. Moving files works in the Windows Command Prompt.

UPDATE: It appears that there may be a security restriction on my laptop that either prevents accessing/copying/executing the "mv.exe" program by its name or by its heuristics. Still willing to accept workarounds that replace the mv command as mentioned above.

UPDATE 2: Screenshots in windows command line and when I open mv.exe in Windows.

windows command prompt

enter image description here

UPDATE 3: output of file command:

┌─[12:36:09]─[mbutl2@MYHOSTNAME]
└──> ~ $ >> file /usr/bin/mv
/usr/bin/mv: writable, executable, regular file, no read permission
┌─[12:36:15]─[mbutl2@MYHOSTNAME]
└──> ~ $ >> chmod 777 /usr/bin/mv
chmod: changing permissions of `/usr/bin/mv': Permission denied
┌─[✗]─[12:36:29]─[mbutl2@MYHOSTNAME]
└──> ~ $ >> mv
-bash: /usr/bin/mv: Permission denied
┌─[✗]─[12:36:35]─[mbutl2@MYHOSTNAME]
└──> ~ $ >>

ldd also reports permission denied.

share|improve this question
    
try changing the file permissions Mv.exe,see this article:uwec.edu/Help/drives/permissions.htm –  QMechanic73 Jul 8 '13 at 19:32
    
Does this also happen in the Windows command prompt (cmd) ? –  harrymc Jul 8 '13 at 19:58
    
It's worth checking that the permissions on c:\cygwin\bin\mv.exe, in both Windows and Cygwin, permit execution for the accounts you're using. Also, see what happens when you double-click that executable in Windows Explorer -- if you see a UAC prompt, then that's why you're getting the error in Cygwin, and it will occur regardless of permissions; I do not know a way of working around that except to disable UAC entirely, which is rarely desirable. –  Aaron Miller Jul 8 '13 at 20:58
    
I updated the question with screenshots on what happens in the proposed scenarios. If UAC is causing this, is that controlled by the file name, file path, or some kind of hash key of the executable. In other words, could I change the executable (or create a new one) that does the same thing but lives somewhere else, with a different hash signature? –  Michael Butler Jul 9 '13 at 13:18
1  
@MichaelButler: what is your antivirus? –  QMechanic73 Jul 9 '13 at 16:49

3 Answers 3

  • See if the file has been blocked by Windows.

    Check the properties of the file, there may be a note saying This file came from another computer and might be blocked to help protect this computer To check for and unblock the file, follow these steps: Right-click the blocked file and then click Properties. In the General tab, click Unblock if the option is available.

  • Check to see if your antivirus is blocking the file.

    You can check to see if your antivirus software is blocking a file by temporarily disabling it, and then trying to open the file.


Update:

  1. Right-click the file or folder, and then click Properties.
  2. Click the Security tab.
  3. Under Group or user names click your name to see the permissions you have.
  4. Click Edit, then check the check boxes for the permissions that you need and then click OK.

Result:

enter image description here


Update 2:

Try this:

  • Right click, select Properties.
  • Click the Security tab.
  • Click Advanced.
  • Click the Owner tab.
  • Change owner to yourself.
  • Click Edit.
  • Check Replace owner on subcontainers and objects.
  • Click OK.
share|improve this answer
    
Properties didn't say anything about coming from another computer. Antivirus is VirusScan Enterprise (managed through a network). I can turn the auto-scan off via toggle switch, but this has no effect on opening, moving, or renaming the mv.exe file. –  Michael Butler Jul 9 '13 at 18:02
    
Interesting. When I set permissions in the Security tab on the FOLDER, I get "Access denied" on setting permissions on the mv.exe. Screenshot attached. –  Michael Butler Jul 9 '13 at 18:41
    
@MichaelButler: Updated my answer. See if you can now. –  QMechanic73 Jul 9 '13 at 19:29
up vote 2 down vote accepted

The workaround was to re-download Cygwin's mv.exe utility, saving it as a different name like mvvv.exe (before actually downloading it, since I don't have access to rename mv.exe). Then, I set up a symbolic link to point mv to mvvv.exe so I can use it normally.

share|improve this answer
    
You should be able to create a symbolic link: ln -s mmv /usr/bin/mv to use mv on prompt and/or scripts. Except something is special with the filename mv on your machine... –  mpy Jul 10 '13 at 18:26
    
Since McAfee seems like the problem, is my answer an option here (getting rid of this monster) ? –  harrymc Jul 10 '13 at 18:30
    
@mpy Thank you! Brilliant workaround. A lot better than using an alias. 'mv' is fine since I'm in Cygwin and don't need "exe". "mv.exe" is the problem. I did a slink to mvvv.exe called mv and everything is normal now. –  Michael Butler Jul 10 '13 at 21:15
    
@harrymc sorry Harry, while McAfee was the problem, I think a solution is the best answer (the symbolic link to a differently named mv.exe) –  Michael Butler Jul 15 '13 at 13:07

Just in case that something went wrong on your disk with mv.exe, I would try to :

  • uninstall Cygwin
  • chkdsk
  • verify that mv.exe was deleted with its entire folder
  • reinstall Cygwin

[EDIT]

You say that your antivirus is McAfee, which in my opinion is one of the most problematic of all antivirus products.

I would suggest to disable real-time protection in McAfee to see if the problem goes away. If it does, my own recommendation is to uninstall McAfee and install some other less-intrusive antivirus product.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.