Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On the client side:

rsync -x -r -t -v -o "nobody" -g "nogroup" --progress --delete -u --partial -s -e ssh /home/john/Calibre\ Library root@192.168.0.21:/media/Book

On the server side:

clementine:/c/media/Book# ls -la
total 20
drwxrwxrwt   3 nobody nogroup  4096 Jul  1 20:34 .
drwxrwxrwt  13 nobody nogroup  4096 Jul  1 19:24 ..
drwxr-xr-x 246 backup users   12288 Jun 30 17:37 Calibre Library

I have no idea why it changes the user and group and doesn't assign to the right one. Why is this?

share|improve this question

1 Answer 1

Update:

I'm starting to think that your problem might be related to the UID/GID being different on your machines.

A user on this site explains the following:

You don't have the usernames in /etc/passwd on the new server and that's why the owner/group names are not seen on the files you copied over.

Just copy over the appropriate entries in /etc/passwd, /etc/shadow, and /etc/group from the old server to the new one and that should be it.

Does that make sense? In the comments I mentioned using the "stat" command on certain files/folders both on the client and server. Part of the output of stat will display the UID and GID. This may help in determining differences between the client and server.

Original Answer:

I see that you have "root@192.168.0.21", but go ahead and make sure to add the "--super" option to your command.

rsync -x -r -t -v -o "nobody" -g "nogroup" --super --progress --delete -u --partial -s -e ssh /home/john/Calibre\ Library root@192.168.0.21:/media/Boo

Linux man page:

-o, --owner
This option causes rsync to set the owner of the destination file to be the same as the source file, but only if the receiving rsync is being run as the super-user (see also the --super and --fake-super options). Without this option, the owner of new and/or transferred files are set to the invoking user on the receiving side.

share|improve this answer
    
It still don't work. :-( It use "backup" and "users" instead of "nobody" and "nogroup". I don't understand.... –  zobi8225 Jul 2 '13 at 10:36
    
➜ ~ rsync -x -r -t -v -o "nobody" -g "nogroup" --super --progress --delete -u --partial -s -e ssh /home/zobi8225/Calibre\ Library root@192.168.0.21:/c/media/Book [...] rsync: link_stat "/home/zobi8225/nobody" failed: No such file or directory (2) rsync: link_stat "/home/zobi8225/nogroup" failed: No such file or directory (2) Calibre Library/ [..] –  zobi8225 Jul 2 '13 at 10:55
    
Can you paste the output to the following commands? On the client side: stat "/home/john/Calibre\ Library" On the server side: stat "/c/media/Book" –  dtmland Jul 2 '13 at 16:42
    
Client side : pastebin.com/JA8d5BMf Server side : pastebin.com/JD3F0r95 Thanks –  zobi8225 Jul 3 '13 at 14:59
    
That looks like output from your rsync commands? Can you instead post output for the stat commands as listed above? –  dtmland Jul 3 '13 at 15:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.