Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I could swear that Windows (XP) used to show the width and height of images in Explorer if I toggle the Dimensions column, but now it is showing nothing (see screenshot below).

I am working with folders containing many images, so I need to see be able to instantly see the dimensions of pictures as well as sort them.

Am I crazy or did this used to work? What’s wrong and how do I fix it?

Screenshot of Explorer with a blank Dimensions column

share|improve this question
up vote 0 down vote accepted

I feel your pain ◑‿◑ (hey, others might find their way here).

One thing to check is the perceived type for images. For example, to ensure that the type for JPEGs is correct, check the registry for the following (or modify if necessary):


However this may not work (it didn’t for me) and the setting may already be correct.

Another, easier, faster, simpler, and safer way to fix this issue (which worked for me) is to simply re-register Windows built-in image-handling shell-extension (should work in Windows 7 as well):

regsvr32 shimgvw.dll

You’ll need to restart Explorer for it to take effect (reboot, log out and in, or kill Explorer and run it).


Screenshot of Explorer with the Dimensions column populated

As to why it wasn’t working, I don’t know. Obviously some setting (likely in the registry) had been changed (e.g., a program associated various image types). It may also have been changed by disabling a file-handler or some such. If I get some time to do some experiments, I’ll try to determine the exact setting, but fixing it is as simple as running the above command (and restarting Explorer).

share|improve this answer
It should work for other versions of Windows like Vista and 7 as well. – Synetech Jul 21 '13 at 1:20

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.