Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am currently running a Linksys WRT160N router on DD-WRT set up as a "Repeater Bridge". It currently serves to rebroadcast my Virgin Mobile MiFi's WiFi through this router, hence broadcasting a more powerful signal. The issue I have is sometimes the computers connected to the DD-WRT router take a while to fully connect as the DHCP is delayed for some reason as it is coming from the MiFi and the requests are all forwarded, etc. It significantly delays everything.

What I am wondering is if there is a way to get a DHCP server running on this DD-WRT router in "Repeater Bride" mode or a mode with an identical function, that way I can turn the DHCP Off on the MiFi and the delay will be eliminated.

Any thoughts are useful, Thanks c:

share|improve this question
    
If you can possibly switch to WDS, do so. It "just works" rather than faking it with NAT. –  David Schwartz Jul 2 '13 at 3:00
    
@DavidSchwartz can you explain how I would accomplish this? –  seanthewebber Jul 2 '13 at 3:09
    
Honestly, I don't think your setup makes sense unless the Virgin Mobile device is capable of WDS. You need something to be a device on the MiFi router and something to be an AP to broadcast the more powerful signal. That's not repeating. I would switch to more sensible hardware such as two WiFi devices back-to-back. –  David Schwartz Jul 2 '13 at 8:17
    
Unfortunately the Virgin Mobile device isn't compatible with WDS. The issue without use of a (basically) always running dedicated computer, the Virgin Mobile device only broadcasts its connection as WiFi, this means either I'd have to plug it into a computer with USB and Bridge the USB connection to Ethernet and plug a DD-WRT AP into that, or use one device to connect to it via WiFi, bridge that to an Ethernet cable, and then hook that to another DD-WRT AP. Either of those methods require at least another device in line... –  seanthewebber Jul 3 '13 at 18:36
    
Yep. It's a pain to get dumb devices to do things they weren't designed to do. –  David Schwartz Jul 3 '13 at 18:38

1 Answer 1

Alright guys, I figured out a back way of doing this that surprisingly the internet tutorials said NOT to do.

Once the device was 30/30/30 reset, I followed the directions at http://www.dd-wrt.com/wiki/index.php/Repeater but modified a couple of things under the "Basic Setup" tab.

Note that my MiFi (In this case Primary router) is "192.168.0.1" using the Subnet "255.255.255.0".

The Basic Settings of my Secondary (DD_WRT Router):

Local IP Address: 192.168.1.1
Subnet Mask: 255.255.255.0 
Gateway: 192.168.0.1
DNS: 192.168.1.1

And being "Repeater" mode has DHCP Enabled, the Secondary router handles DHCP (And as it says up there, DNS. I forwarded that to Google's DNS servers at 8.8.4.4 and 8.8.8.8 for reliably.)

In this setup the LAN and WLAN on the Secondary router all operate normally as they would, and I can access the 192.168.0.* and 192.168.1.* subnets when connected to the secondary router.

share|improve this answer
    
@David Schwartz You might like? :) –  seanthewebber Jul 10 '13 at 16:12
    
What was funny about the Internet tutorials they said to use a DIFFERENT subnet mask that wouldn't allow me to access 192.168.0.* IP Addresses when connected to the Secondary router. –  seanthewebber Jul 10 '13 at 16:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.