Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After upgrading from Windows 8 Pro with Media Center to the 8.1 preview, I need some help in being able to watch live TV again.

When I try to now, it says Please Wait. Searching for tuners.

I tried reinstalling the software for the Hauppauge WinTV DCR-2650 TV tuner, and upgrading the firmware for both the tuner and the Cisco STA-1520 tuning adapter.

I also tried swapping around the USB ports, cold-booting the devices, and running the Set Up TV Signal setting in WMC, but that says The TV signal cannot be configured because a TV tuner was not detected.

Both devices look fine in Device Manager, reporting the "This device is working properly" status.

I'm not sure if this is related, but I did have some network connectivity issues immediately after upgrading to Windows 8.1 where my either my subnet mask or default gateway was missing, and since the TV tuner shows up as a network device, I wonder if that might be related. However, I really don't know how those settings should look and Hyper-V sort of further complicates things with the virtual Ethernet adapters: TV Tuner IP configuration

share|improve this question
Sounds like a conflict between your turner and the preview. I would roll back the system to Windows 8 until the RTM release. – Ramhound Jul 2 '13 at 11:24

2 Answers 2

up vote 0 down vote accepted

The issue turned out to be network related after all. I guess the Windows 8.1 Preview update really wreaked havoc on those settings.

To do so I had to delete the network devices related to the TV tuner. In my case this had to be done in the snap-in, Hyper-V Manager.

From the Action menu, in the Virtual Switch Menu, I removed the the virtual switch associated with the TV tuner. After reinstalling the tuner's drivers, WMC was able to see the tuner again.

As far as I can tell the settings were fine. The only difference here is I'm no longer using the virtual adapter (which I had been before the upgrade).

Network settings after removing hyper-v's virtual switch and adapter

share|improve this answer

I found this site when I had an identical problem with my Windows 7 TV signal. After contacting my cable company and confirming that my cable card was getting a signal, I went to the Hauppauge FAQ site.

The answer was there: an update of my Norton 360 protection suite had blocked the DCR's access to the signal. Specifically, the 'Default Block UPnP Discovery' & 'Default block SSDP' must both be unblocked. Reboot the computer after removing those two blocks and the problem is solved.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.