Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running Windows 8 on a domain joined machine (i have local admin, not domain admin). I have VM's on hyper-v and I want to share a folder without requiring the VM's to logon. The VM's are setup on a internal network.

I've shared a folder with read perms for "Everyone" and when I try to access it from the VM's it always asks for credentials.

Thanks for the help!

share|improve this question
    
What happens if you give your user specific access instead of using "Everyone"? – Ƭᴇcʜιᴇ007 Jul 2 '13 at 16:54
    
I don't know how that would work. My host machine is domain joined and the VM's are not. I'm logging into all of them as Administrator. I tried giving administrators access but it still asks for credentials. – JonFriesen Jul 4 '13 at 17:06
up vote 2 down vote accepted

Since 2003/XPSP2 the Everyone group does not include the Anonymous/Guest account.

You can edit the security policies of the domain (or the local security polices of each non-domain-joined VM in your case) via secpol.msc to include that Anonymous account back in.

The policy to change/enable is Computer Configuration\Policies\Windows Settings\Security Settings\Security Options\Network Access: Let Everyone permissions apply to anonymous users.

You can get the same effect by modifying the registry directly:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\LSA\EveryoneIncludesAnonymous - set it to 1 (REG_DWORD) to enable the rule.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .