Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a NVidia GeForce GTX 660, connected to a Samsung SyncMaster S24B350 through a HDMI cable. On my computer, I'm running both, Windows 8 and Linux Mint.

I think that something might prevent my system from using the whole RGB spectrum, since bright colors seem to vanish into white under standard settings. However, under Linux I could switch to a limited color range mode (16-235) and suddenly, the image looked much better.

  1. Is it possible that the HDMI cable limits color range (since it was originally inteded for TVs)?
  2. Is there a way of switching to limited color range mode in Windows 8 as well?
share|improve this question
1  
The anwer to 1 is definitely no. –  David Schwartz Jul 2 '13 at 18:13

2 Answers 2

up vote 3 down vote accepted

This has nothing to do with HDMI, and likely nothing to do with your graphics card.

Your monitor has settings to optimize the picture. It's not uncommon to try to make an image appear as if it were of higher contrast by lightening up the brights and lowering the darks. There are also various color "enhancements" to make the monitor look good that will affect things. Disable these features of your monitor, and this problem will go away.

share|improve this answer
    
+1 Correct. Configure the monitor properly. –  Tonny Jul 2 '13 at 18:40
    
I had already played around with it (disabled MAGICColor, changed gamma, contrast and brightness settings), but it only helped little. Is it possible that my monitor has just poor color fidelity? It cost about 200 dollars, which is obviously not high end... –  Cedric Reichenbach Jul 2 '13 at 19:05
    
@CedricReichenbach, Yes, that is entirely possible. While monitor price does not necessarily reflect quality, I've only had one set of monitors around that price range that had good color range and contrast. –  Brad Jul 2 '13 at 19:13

I wasn't able to find anything related to RGB range of the HDMI technology in the specifications. However, I find it very hard to believe that the RGB support is so bad that you can't see the color correctly. Try to:

  • Check the setting of the SyncMaster
  • Double check the HDMI cable and connection
  • check for driver updates.
share|improve this answer
    
I already went through those steps earlier. Changing monitor settings help a little bit, but not much. Maybe my monitor was just too cheap... –  Cedric Reichenbach Jul 2 '13 at 19:08
    
As far as I know, SyncMaster monitors are actually pretty good screens. Try connecting the HDMI cable to another screen, even TV will be good enough. –  matan129 Jul 2 '13 at 19:12
    
Ok, I could try changing it with another HDMI cable (that perfectly supplies a TV), but I guess Brad's answer/comment makes sense and the monitor is to blame. –  Cedric Reichenbach Jul 2 '13 at 23:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.