Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

While watching movie using VLC with czech subtitles, qestionmarks appears instead of some (ěščřž etc.) characters. Steps that I have tried so far:

  • Converting subtitles from windows-1250 to utf-8 using iconv:

    iconv -f WINDOWS-1250 -t UTF-8 1250.srt > utf8.srt

I assume that conversion was successful because when I open windows-1250 version (with vim or gedit) I saw strange characters, after conversion to utf-8 subtitles looks OK, so it seems that that from/to format was chosen correctly.

  • Setting various combinations in VLC player "default encoding" font and subtitles settings.

I guess that something is wrong with language support on system wide level or something similar.

Thank you

share|improve this question
    
Can you upload a sample Czech subtitle file so I can check it? –  matan129 Jul 2 '13 at 19:20
    

1 Answer 1

No need to convert the subtitle file. Try this: open VLC, go to Tools > Preferences > Subtitles & OSD and under defualt encoding change the encoding to Eastern European (Windows 1250)

(you said you have tried some combinations, but I don't know which ones)

share|improve this answer
    
I have tried 1250, 1252 and of course utf-8 with same result. –  Wakan Tanka Jul 2 '13 at 19:29
    
It should work with 1250. Try to restart VLC. meanwhile, I'm downloading this subs just to check, but since I don't know Czech at all I will upload a screenshot of the subtitles. –  matan129 Jul 2 '13 at 19:32
    
Yep, I've changes the default encoding to 1250 and restarted VLC and it seems fine to me - please confirm. Image (ignore the movie, I checked just the subtitles). Note: Before I've change the encoding to 1250 it was gibberish, like you have mentioned. –  matan129 Jul 2 '13 at 19:39
    
Yes your subtitles looks OK, I have exactly the same VLC settings with font "Nimbus Sans L" I do not understand. –  Wakan Tanka Jul 2 '13 at 19:44
    
It may be issue with the font itself, maybe it's not mapped to Czech. Try with the Arial font. Remember to restart VLC! –  matan129 Jul 2 '13 at 19:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.