Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

On the Google Chrome permissions page, it says that you can change Fullscreen permissions.

However, when clicking the permissions, I can only change to allow on this page or ask:

enter image description here

I want to be able to always allow on any site, like some other permissions have:

Is this possible? I also want to get rid of this:

enter image description here

share|improve this question

marked as duplicate by random Feb 17 '15 at 2:03

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

up vote 15 down vote accepted

EDIT: I found out the reason Chrome prompts is because this is a security issue where sites could possibly impersonate a browser environment.

I got it to work on my machine by using Google's host pattern matching.

  1. Open Chrome's Content extensions paste this into an address bar: chrome://settings/contentExceptions#fullscreen
  2. Edit an item to be *://*/* and save (on my machine it disappeared from the list but worked the way I wanted.) (per @Jaex comment below try just * I used both, but I tried the * first and assumed it didn't work when it disappeared from my list.)

Thats it, it worked immediately for me.

share|improve this answer
5  
I used just * and it worked fine. – Jaex Jun 5 '14 at 18:30
    
Worked beautifully. Thanks! – Chris Keele Jun 25 '14 at 1:18
5  
When it disappears from the list, I wonder how you can revert. Maybe through a config file somewhere? – snapfractalpop Jul 16 '14 at 16:53
2  
It's not possible to edit anymore, just to delete (MAC OS on Chrome 46.0.2490.86 (64-bit)) – Murta Nov 17 '15 at 15:40

If you are on windows just edit your Chrome shortcut properties:

Where it says target:

"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe"

add --kiosk to the end

"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --kiosk

It will now run in full screen mode each time you start it.

share|improve this answer
3  
Sweet, do you know of a way to get rid of the "You have gone full screen" message? – Frank Jul 5 '13 at 7:11
1  
From what I know it's not possible to remove that message for now. Could be available in one of the next updates though since people are demanding to remove it. – easwee Jul 10 '13 at 8:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.