Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a unique issue where a client's Internet Explorer will not browse to pages while using a wireless connection. He can ping sites in both LAN and Wireless conifgs, and Firefox is able to open sites no problem in both LAN and Wireless configs, but IE only works while connected to the LAN, not on wireless (both at work and home). I have upgraded to IE 8, Reset IE settings, Restored Advanced Settings, rebuilt the WINSOCK catalog....all to no avail. Ran anitvirus scans with no results. Any ideas?

share|improve this question
    
can you report the IPCONFIG /ALL result ? –  Revolter Oct 27 '09 at 15:23
    
not currently logged in, but the results were correct. IP address is legit, nslookup works, ping works, Firefox works....IE just hangs, and its built in Diagnostic tool reports connecting to ftp.microsoft.com works, but HTTP and HTTPS requests don't work. This also affects the clients Outlook Anywhere abilities, since I believe the programs (Outlook, IE, etc) share the same method of connecting. –  SilkyTech Oct 27 '09 at 15:41
add comment

3 Answers

try going to tools - internet options - connection settings, then click the lan settings button. clear out any check boxes there and see if it works....

share|improve this answer
add comment

can you browse internal (to the network) sites? If so maybe it's a proxy setup issue? Otherwise is the Windows firewall being a little overzealous as that's on a per-interface level.

share|improve this answer
add comment
up vote 0 down vote accepted

Thanks for the suggestions. Unfortunately, I can't tell exactly what it was. I added an exception to the firewall with no luck, and tried different configs in the LAN settings. Eventually, having all boxes unchecked (Automatically Detect Settings would break it if it was checked) seemed to be it, but ONLY AFTER I went into the registry and "hacked" the IE keys. Found something that said to go to HKLM\SOFTWARE\Microsoft\Active Setup\Installed Components{89820200-ECBD-11cf-8B85-00AA005B4383} and change the IsInstalled DWORD Key to "0". I did this, logged off/on, it claimed IE was uninstalled and asked to "clean up" personal settings, which I did, then changed the IsInstalled key back to "1". After a log off/on, I browsed to iexplore.exe in Program Files, recreated the Desktop shortcut, and its working fine wirelessly ever since. Strange happenings.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.