Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running Karmic RC 32-bit. Ran aptitude safe-upgrade this morning, then rebooted. Everything looks fine in GDM, I enter my password, the animation goes for a few seconds and then dumps me to my desktop wallpaper, and AWN, which I have set to automatically start at login.

No desktop icons, no gnome-panel, keyboard shortcuts (like Alt+F2) don't work. I can launch apps from AWN but they open without window decorations.

This happened with one of the Karmic alphas and I just reinstalled. Anyone have a less radical solution?

Edit: People have suggested running metacity --replace and gnome-panel from a gnome-terminal, and this gets me my window decorations and panel. What I'm looking for is, what file or script is responsible for setting up my session and launching these apps at login time, and how can I stop aptitude from breaking it?

share|improve this question
You could start the panel and decorations manually with gnome-panel and metacity --replace or compiz --replace. I had a similar problem ones (window manager, no matter which, didn't start with the session). I don't know what fixed it in the end, but I was going through my home-directory and removed every configuration directory I didn't seem to need (like .gnome2 etc.) until it worked again. – Bobby Oct 27 '09 at 15:44
Duplicate question is here:… – eleven81 Oct 27 '09 at 15:48
Pardon me eleven81, but that's not a duplicate, the seem to be the same, but are completely different. – Bobby Oct 27 '09 at 16:04
up vote 0 down vote accepted

The same thing happened to me when I upgraded to 9.04. Here is what I did:

Hit Ctrl-Alt-F1 to change to a command line terminal and log in.

Now go to the directory `.config/autostart' in your home directory and create a file named 'nautilus desktop'. Copy the following content into that file:

[Desktop Entry]
Name=No Name
Comment=Start Nautilus on login event though this should happen automatically
Exec=nautilus --no-default-window

Now log in to your graphical session again and with a little luck you should see the desktop populated this time.

share|improve this answer
This worked for my desktop items, but I'll have to do the same thing for each app that's failing to launch (gnome-panel, metacity, etc). Will reinstall in a couple days when Karmic is final. – regan Oct 28 '09 at 2:29
Another option is to simply wait for updated versions of the buggy packages. Did you file a bug report for this? – innaM Oct 28 '09 at 9:27
By the way, here is an old bug that sounds very similar: – innaM Oct 28 '09 at 11:06

So you could try moving aside .gconf and .gconfd as recommended here:

Regan, in a comment you say you'll reinstall when Karmic's final - it is now - did that do the trick, or did you have the same problem?

share|improve this answer
I did reinstall when Karmic was released. The issue cropped up again, but I believe I've traced it to Google's dev repository (which I had added so I could use the dev builds of Chrome). I've had no problems running Karmic with several other third-party repos installed (and I use the chromium-daily PPA to update my web browser now). – regan Dec 3 '09 at 14:30

Try running metacity --display=:0 --replace and see what happens? If you have no other way to run it, you can get into a virtual console by pressing Control-Alt-F1. To get back to your desktop, either logout or press Control-Alt-F7.

share|improve this answer

Boot with the recovery mode option in grub, run the xfix option, then continue with a normal boot. It's possible your graphics drivers got borked in the upgrade, and if you are using desktop compositing this would cause issues similar to what you describe.

share|improve this answer

Personally, and as much as I like Linux, I never wanted to trust the upgrade of an operating system, whether this is Windows, Linux, Solaris or else. I consider that any OS is too fundamental and has too many dependencies to be upgradable. Unless this is a service pack, or a fix, of course.

Every time I tried an upgrade of Ubuntu, I was having issues with it.

Also, doing a clean install means doing a full backup, defragmenting the hard disk, and also re-installing ONLY the applications that I really need, not all the little things I accumulated since the last major release.

Yes, this is time-consuming. But the sanity of your computer, and the safety of your data files, regardless of the type of content, is more important.

For myself, i go to an extreme, installing Ubuntu on a separate hard disk, until I see that it can do what I need, and I then proceed with the clean install, after doing a complete backup.

That's my view.

share|improve this answer
I agree with you about preferring a clean reinstall, but this wasn't a dist-upgrade. I installed Karmic RC when it came out, and today I simply ran the standard updates command and it did this. – regan Oct 27 '09 at 20:17
I see. Have you installed other packages, or added third-party sources of packages ? If not, this should be reported ASAP to the developers of Ubuntu, and it get fixed just in time. – jfmessier Oct 27 '09 at 20:27
I've got the AWN testing PPA, a PPA for chromium-browser and the google repos enabled, so the culprit might be harder to nail down. Will try reinstalling and running without third party repos to see if it happens again. Naturally I only run pre-release software on this box cause it's an unimportant home PC. All the important data lives elsewhere, affording me free rein to reinstall as often as I please. – regan Oct 27 '09 at 21:09

I had a similar problem after upgrading to Karmic. I solved by installing the associated nvidia driver (sudo apt-get install nvidia-glx-185)....I am not sure if you have an nvidia-graphics card, but this worked for me.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .