Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Gigabyte GA-EP45 extreme, which contains a "Intel Matrix RAID controller". On lspci outputs as:

RAID bus controller: Intel Corporation 82801 SATA Controller [RAID mode]

I bought two equal hard drives, (WD Caviar Blue(WDC WD10EZEX) to be exact) and i put both together as an array and it works fine, till i boot the operating system.

It recognizes the RAID array and gives it two addresses (/dev/md126 and /dev/md127), and when i first opened a disk manager utility(like the gnome-disk-utility) it tells that the disks are syncing. I didn't understood why were two empty disks syncing, nor knew what were they exactly doing, but judging by the speed and time consumed the whole disk was copied.

When it finished i tried to open a disk format utility (gparted), but it got stuck on the "Scanning /dev/md126" information. I forgot about it, and used the gnome disk utility again, with no success, the disk was formating forever.

I rebooted the computer, and what a surprise when the disk was syncing again... after two hours, i tried to format under the command line, but it is stuck on "Writing partition table to disk..."(cfdisk) How can i format these two drives?

PS: As i got them(or trying to get), if one of them fails, what will happen to the other? Becomes an independent drive? Will i be able to get it working under other computer with no raid controller to copy the data?

share|improve this question
2  
Personally I would just use Linux's built-in software RAID or ZFS. –  rob Jul 3 '13 at 20:14

1 Answer 1

As I got them(or trying to get), if one of them fails, what will happen to the other?

That depends on how you configured the RAID array.

  • If you selected RAID 0 (a stripe) then you loose access to the data on both drives.
  • If you selected RAID 1 (mirror) then nothing seems to change, except for a message that the array is in degraded state and that you should fix this before the next drive fails.

Will I be able to get it working under other computer with no RAID controller to copy the data?

That depends on how you made the RAID.

  • With hardware RAID you would need the same, or a very similar, RAID card.
  • With software RAID such as mdadm you can access it from any computer.
  • With Intel fake RAID you get the worst of both of them. No HW support (except for some BIOS option to help you configure) and it will not 'just work' on any other motherboard.

Intel fake RAID used /dev/DMxxx.
Mdadm uses /dev/mdxxx.

You mention both in your post. Either that is a typo or it is the cause of your problems.
Try setting the onboard disk controller to the normal AHCI mode, boot, wipe the disks, reboot and install.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.