Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a windows machine from which I can ssh into a unix machine with NX called 'London'. Here I can browse the web with firefox after I set the proxy to '' and port 3128. At startup it asks for username and password I type it in and everything works fine.

The problem is that firefox is slow in NX so I thought it would be much better to tunnel to London and use a browser locally on my windows machine, but I don't know how to set up London to use proxy for this connection. I don't have root access to it, so I can't use export.

share|improve this question

Set up a tunnel in your SSH client, from a local port of [whatever really, let's say 31283] to remote Then in your local browser set proxy to localhost:31283.

When you ssh, all connections from local port of 31283 will go to on the remote side, therefore you'll be able to use that remote proxy locally.

share|improve this answer
Thank you for the answer. I tried to simply ssh to from London with 'ssh -p 3128' but nothing happens. No prompt to give in username, no error and I have to cancel it with ctrl+c. – tomzi1 Jul 4 '13 at 8:32
Hmm it seems like firefox not working even with manual proxy configuration, only with automatic proxy configuration with, but there is nothing special in the pac file, for 'other sites' it returns '' – tomzi1 Jul 4 '13 at 8:52
No, it makes no sense to ssh into the proxy. You need to set up the tunnel when SSH-ing to your London host. I don't think NX allows setting tunnels, but since it's AFAIK a standard SSH connection you can use any other SSH client to set up a tunnel. – Divide Jul 19 '13 at 4:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .