Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm tired of GNOME's problems with my Fedora 18 instance, and decided to move on to another desktop environment. After successfully changing to Xfce, I still couldn't get rid of GDM which annoys me a lot: it is super slow and slows down my boot time by 2 seconds, sometimes more.

I have installed slim but just installing didn't change anything. After searching thoroughly through Google, the only solution I found was to edit the file /etc/sysconfig/desktop but it doesn't work. The file doesn't even exist. Either way, I created it and edited as it was told (DISPLAYMANAGER="SLIM") and... it doesn't work.

Other websites told to edit /etc/X11/prefdm file but guess what? This doesn't exist too. And now I'm getting afraid of changing and creating such files, as I have already rendered my system unbootable more than 10 times this year.

I'm out of ideas to make it happen, how can I replace the shitty GDM with SLiM?

share|improve this question

2 Answers 2

Just disable gdm.service and enable the service unit for your preferred display manager, so something like:

systemctl disable gdm.service
systemctl enable lxdm.service

Would switch from gdm to lxdm.

share|improve this answer
I already did it, but Fedora is very stubborn and this does not make any changes. I managed to change to LightDM with system-switch-displaymanager, but this tool is very limited (works only with GDM, KDM and LightDM) and I want SLiM for now –  ranisalt Jul 4 '13 at 7:40
@ranisalt: Does SLIM have a systemctl service file? –  Ignacio Vazquez-Abrams Jul 4 '13 at 7:51
As far as I can see SLIM is not packaged at all for Fedora so @ranisalt would need to package it himself (or install from source) and part of that would be to write a service file - it's pretty trivial if you just copy the gdm one and tweak it. –  TomH Jul 4 '13 at 8:24
Slim is present in official repositories and the package provides slim.service file. –  ranisalt Jul 4 '13 at 22:13
up vote 0 down vote accepted

So I managed to do that. It is very dark in Fedora how to change that, but I could make it. So: I backuped /etc/systemd/system/display-manager.service and deleted it, and then made a symlink to /usr/lib/systemd/system/slim.service for the same file. Now, display-manager.service redirects to slim.service when before it redirected to gdm.service.

I don't really know why this is not changeable easily. Neither installing another DM nor disabling the actual one changes, because you have to disable display-manager and not the specific DM service.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.