Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use the winexe tool in order to run cli command on my WIN xp from Linux machine

as the following example ( from my Linux )

  • 10.18.15.132 - IP of the WIN XP machine

     ./winexe -U  Cellcom/SDnet%w5frdlpp  //10.18.15.132 "ipconfig"
    

Windows IP Configuration Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix  . : Cellcom
    IP Address. . . . . . . . . . . . : 10.18.15.132
    Subnet Mask . . . . . . . . . . . : 255.255.0.0
    Default Gateway . . . . . . . . . : 10.18.15.0

but today when I run the winexe I got the following error?

   ./winexe -U  Cellcom/SDnet%w5frdlpp  //10.18.15.132 "ipconfig"


    ERROR: Failed to open connection - NT_STATUS_ACCOUNT_LOCKED_OUT

after 1/2 hour I run the winexe again and now its ok

So I don’t understand why I get "status account lock" for 1/2 hour ??

  • What could be the problem, and if I get lock how to un-lock?

  • what’s the steps that should be done in order to unlock ??

WINEXE info

  winexe version 1.00
  This program may be freely redistributed under the terms of the GNU GPLv3
  Usage: winexe [-?] [-?] [-?] [-?NP] [-?NPV] [-?|--help] [--usage] [-d|--debuglevel     DEBUGLEVEL]
      [--debug-stderr] [-s|--configfile CONFIGFILE] [--option=name=value]
      [-l|--log-basename LOGFILEBASE] [--leak-report] [--leak-report-full]
      [-R|--name-resolve NAME-RESOLVE-ORDER]
      [-O|--socket-options SOCKETOPTIONS] [-n|--netbiosname NETBIOSNAME]
      [-S|--signing on|off|required] [-W|--workgroup WORKGROUP]
      [--realm=REALM] [-i|--scope SCOPE] [-m|--maxprotocol MAXPROTOCOL]
      [-U|--user [DOMAIN/]USERNAME[%PASSWORD]] [-N|--no-pass]
      [--password=STRING] [-A|--authentication-file FILE] [-P|--machine-pass]
      [--simple-bind-dn=STRING] [-k|--kerberos STRING] [-V|--version]
      [--uninstall] [--reinstall] [--system]
      [--runas=[DOMAIN\]USERNAME%PASSWORD] [--runas-file=FILE]
      [--interactive=0|1] [--ostype=0|1|2] //host command
share|improve this question

1 Answer 1

The Windows account is locked. If you are on a Domain network, Check "Active Directory users and computers" for the user account in question and make sure you unlock the account.

If you are NOT on a domain, You will need to go to the windows computer that is hosting the account and unlock the account. To do so perform the following:

  • Start > Run > Compmgmt.msc > Enter

  • Expand Local users and groups

  • Located the user, Double click it and unlock it.

Hope this helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.