Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I noticed my setup is running in IDE mode, which I changed to AHCI in bios.

1) SSD with Windows 8, booted up successfully in safe mode, after that, booted up in normal mode easily 2) 1TB HDD with some precious data on it, it also has old Windows 7 installed, which is no longer bootable, but I can't delete that folder 3) 2TB HDD with some movies, boots just fine

My problem is that after switching to AHCI, I can see the #2 HDD in BIOS, but I can't see it in Windows 8. I checked device manager if it only hasn't lost it's drive letter, but it's not here either.

Anyone can help me?

share|improve this question

If you install windows while in IDE mode then then switch to AHCI mode afterwards it can cause problems as windows disables the AHCI driver during the OS install (and vice versa for switching from AHCI to IDE mode).

I have had the same problem as you before and managed to switch windows over to AHCI by manually enabling the driver in the registry.

You could try doing this method for your windows 8 installation.

And this method for your windows 7 installation.

Make sure you read the steps correctly as you have to everything in the right order before changing to AHCI mode in the BIOS.

Disclaimer: Messing with the registry and especially messing with the hard driver controller drivers can result in windows not being able to boot. Attempt these fixes at your own risk.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.