Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a new Windows Server 2008 R2.

I have IIS 7.0 running with a couple of web sites.

I installed Google Chrome on the machine and it worked great, yesterday.

Today, I went to Chrome to look some stuff up and whenever I navigate to Google.com it ALWAYS redirects me to google.com.tr (Google Turkey). I can get to other sites w/o issue. Just not Google.com

Clearing browser settings/history, etc... fixes the issue - temporarily. Navigating away and back the issue returns.

Is this a virus, or a bug in Chrome?

EDIT

This server is an Amazon EC2 Cloud system I believe running in their Oregon (US-West) datacenter.

I am not located in Turkey but central USA.

I have confirmed that ICANN has my server's ip address in seattle washington. On my Amazon EC2 dashboard, the server location is Oregon (US-West).

I am currently running a full av scan - the quick scan found nothing unusual.

Curiously, while i can get to other web sites, ads that are served are served in what I think is Turkish!

share|improve this question

3 Answers 3

up vote 3 down vote accepted

Google will send you to the domain depending on your IP location. It is most likely that your IP address is being picked up as being outside of your actual location.

Are you using a proxy to connect to the internet? This could be routing your traffic to an IP that is outside your actual location.

It is possible that you have a malicious program that is re-routing your info but it is most likely a miss-identification. I would do a WHOIS your IP and see where it is registered.

See this page for more information from Google: https://support.google.com/websearch/answer/873?hl=en

share|improve this answer
    
I should have mentioned this is and Amazon EC2 Cloud system. –  Android Addict Jul 5 '13 at 16:18
    
That could very well be where the IP problem is coming from. You can use the link that I provided to tell Google where you are. Just follow the directions at that site to correct the problem. –  Atari911 Jul 5 '13 at 16:38
    
Thank you - following the link you provided has appeared to fix the problem - time will tell though. –  Android Addict Jul 5 '13 at 16:43

Do the following:

  • Check your hosts file and proxy settings.
  • Be sure that they're default (however you have them normally).

In addition to that:

  • Be sure that wherever you are doesn't have some sort of peculiar DNS settings.

If they are (default), and they don't (the network you're on has standard DNS settings, nothing has changed etc.) and you do not live in turkey, then it is possibly malware.

What "version" of google you're directed to is based on the country of your IPs origin.

share|improve this answer

I would start by checking my ip address and where ICANN thinks it is located. There are a lot of sites that offer this service, one of those is: http://whatismyipaddress.com/

Then:

  • is it just chrome or firefox, opera, internet explorer as well?

    • if it is just chrome i'd check the default language settings chrome://settings/languages and look for turkish if any.
  • if it still persists then use google search encrypted from https://encrypted.google.com/ it is more secure anyway and it wont redirect you because its on its security policy.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.