Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This thread may be similar to Any way to disable specific CPU idle (Cx) states?

I have USB 2.0 CMOS sensor camera that needs to be controlled VIA labview. However , when it captures images sequentially, I notice there is a tear in the image randomly. Upon questioning this with the camera company , I was told the following:

The low frame rate using USB cameras and damaged images of FireWire cameras are caused by the idle states of the CPU. As far as we know, following happens: The communications controller receives a list of commands from the CPU. It starts to execute this list. Now the CPU is idle again and changes in the C3 state for power saving. When the communications controller has finished the command list, it asks the CPU for new commands. While it waits for the CPU coming from C3 into C0, the video capture device keeps sending data, which are not picked up by the communications controller. This causes a buffer overrun and leads to lost data blocks. The USB camera driver can detect these incomplete images and will drop them. The FireWire camera driver can not detect them and therefore you will see the disturbed images. In case you use an Intel CPU, you may try Processor Idle State Manger. It tries to prevent the CPU going into C3 state. The program can be downloaded from

Here is an example of ImageTear :

image tears This certainly means its because of the CPU Cx states. Is there anyway I can disable them and try capturing images again, My system is always ON. So there is no worry of power issues or power efficiency managements.

share|improve this question
"Always ON" does not mean "always running at 100% CPU usage". That's the point of CPU C-/P-states. – grawity Jul 5 '13 at 19:47
Oh so those two are different. Like Vanadis said I want to try the BIOS setting but want to do it correct. – abhilash sukumari Jul 5 '13 at 19:51

You should be able to disable C- and P-states in the BIOS or UEFI. Also you can disable them in the advanced energy-menu in the control panel (assuming you have windows...)

share|improve this answer
I have Microsoft Windows 7 (6.1) Home Premium Edition Service Pack 1 (Build 7601) and Intel(R) Core(TM) i7-2600 CPU. Could you please help me out how to do it in BIOS, I am fairly new to this editing in BIOS. I dont want to do it wrong, and one more question : Is there any other problems if we edit this in BIOS ?? – abhilash sukumari Jul 5 '13 at 19:50
In my BIOS , under power management I see only "Deep sleep mode". IS this the one to be disabled. – abhilash sukumari Jul 5 '13 at 21:15
ACPI Suspend Mode - (1) S1(POS) (2) S3(STR) - Currently in (2) – abhilash sukumari Jul 5 '13 at 21:47

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.