Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed tor and vidalia on Ubuntu 12.04 x64. When I try to run Vidalia, I get the following message

Vidalia detected that the Tor software exited unexpectedly. Please check the message log for recent warning or error messages.

Here's the log

Jul 05 16:56:24.348 [Notice] Tor v0.2.2.35 (git-73ff13ab3cc9570d). This is experimental software. Do not rely on it for strong anonymity. (Running on Linux x86_64)
Jul 05 16:56:24.348 [Notice] Initialized libevent version 2.0.16-stable using method epoll. Good.
Jul 05 16:56:24.348 [Notice] Opening Socks listener on 127.0.0.1:9050
Jul 05 16:56:24.348 [Warning] Could not bind to 127.0.0.1:9050: Address already in use. Is Tor already running?
Jul 05 16:56:24.348 [Warning] /var/run/tor is not owned by this user (jeffrey, 1000) but by debian-tor (118). Perhaps you are running Tor as the wrong user?
Jul 05 16:56:24.348 [Warning] Before Tor can create a control socket in "/var/run/tor/control", the directory "/var/run/tor" needs to exist, and to be accessible only by the user account that is running Tor.  (On some Unix systems, anybody who can list a socket can conect to it, so Tor is being careful.)
Jul 05 16:56:24.348 [Warning] Failed to parse/validate config: Failed to bind one of the listener ports.
Jul 05 16:56:24.348 [Error] Reading config failed--see warnings above.

Running sudo /etc/init.d/tor status results in tor is running.

Does anyone know what's going on here and how I can fix it?

share|improve this question

2 Answers 2

As it says

Could not bind to 127.0.0.1:9050: Address already in use

You probably have the tor daemon enabled and running. So it starts automatically each time you boot the system

You can edit

/etc/default/tor

and set there

RUN_DEAMON="no".

share|improve this answer
    
Thank you its fixed my issue. but wondering why it is happening –  shekhar Apr 19 at 7:37

Type the following command in the terminal:

sudo killall tor

Restart Vidalia and it should work with tor. But the real problem is that every time you want to use tor with Vidalia, you will need to input that command in the terminal.

Problem: Upon installation, tor will automatically start-up when booting Ubuntu. When you open Vidalia, it will first check if there is an existing tor process and try to connect to the control port of tor.

All we need to do is reconfigure tor so it allows Vidalia to connect and start using the tor process.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.