Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Yesterday I want to set up a web server on my computer.After installing some software(probably MySQL cause the problem,I think),there is an odd problem with my Windows 7.

I'm an admin user,but now I can't change some advanced system settings,for example,environment variables and vitural memory,the buttons are gray.What's more,when I open devices manager,a window pops up and say that I can only view,but can't make any changes because I'm a standard user.However,if I search device manager in start menu,right click and run it as admin,I can make changes.The same thing apply to other admin tools like msconfig and gpedit.msc.Also,in the past,when I run some installer,there will be UAC prompt to run it as admin,but now there isn't,and if I just run it by double click,it will run as non-admin and the installtion fails.I have to right click and run it as admin.

I have a guess about the problem:when you run some things,such as administrative tools,windows run them as admin by default(if you are an admin user).But now,the installtion of some software mess up some system settings so windows doesn't run them as admin by default,and cause my problem above.

I tried to create another admin user,and everything is normal when I log in as that user,no such problem.Unfortunately,I have to use my old user,for some reason.

Please help me deal with the problem.Thanks.

UPDATE: I managed to gain access to environment variables and vitural memory settings by killing exlorer.exe process and re-running it as admin.But then everything I run automatically has admin privilege,and I don't want that to happen.

share|improve this question

1 Answer 1

up vote 1 down vote accepted
  • Try UAC settings Change to Notify me only when programs try to make changes to my computer.

enter image description here enter image description here

share|improve this answer
    
Sorry,my but my UAC setting is already at this level.I tried to change it to the lowest level,but the problem still exists. –  Lsmll Jul 6 '13 at 0:47
    
Have you tried to create a new user could be problem with the current user environment. –  Homer Simpsons Jul 6 '13 at 0:49
    
No,I can create new admin users,and as said above,new users don't have the problem.I do have admin privilege,but the problem is administrative tools isn't automatically run as admin.For example,I can right click and run msconfig and gpedit.msc as admin,no problem.But if I run them by left click,it denied access and say I'm a standard user. –  Lsmll Jul 6 '13 at 0:57
    
However,advanced system settings like network ID and environment variable,they are in explorer.exe,there is no way to right click and run as admin. –  Lsmll Jul 6 '13 at 1:00
    
1. Create other admin account login into it 2. Remove the faulty one without deleting files 3. Rename AdminFolder in c:\users\ 4. Recreate the first admin 5. Move old files to new user created directory OR take ownership and delete the created folder and rename it back to orginal ... This should fix it –  Homer Simpsons Jul 6 '13 at 1:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.