Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After upgrading from Vista to Windows 7, I find that I cannot Pin the application "Shiretoko (64-bit)" to the taskbar without it getting a label of "Shiretoko (64-bit) (2)". I don't have any other icons on my taskbar with a similar name. I've tried unpinning it and re-pinning it. I've uninstalled and reinstalled Shiretoko (with a restart in between), but the pinned icon name always gets the (2) appended.

I can pin "Shiretoko (Safe Mode) (64-bit)" and it pins without the (2), so the problem seems to be unique to the normal-mode icon.

How can I fix this situation? It's only a minor annoyance, but I don't see how I can correct it. Where is the configuration for these pinned icons stored?

Edit: If I try to edit the properties for the pinned shortcut and rename it to the desired name, it gets renamed with a (3) appended, indicating that there must be something using the desired name.

share|improve this question
add comment

5 Answers

up vote 4 down vote accepted

After some research, I found a hidden folder

%appdata%\Microsoft\Internet Explorer\Quick Launch\User Pinned

I had searched around here, thinking that Quick Launch and Taskbar pinning were very much the same, but I hadn't seen it because it was hidden. In that folder, there was a shortcut with the desired name. Why that shortcut didn't appear on the taskbar, I don't know. I deleted that shortcut, then re-pinned the application, and it now appears with the correct name.

share|improve this answer
add comment

This problem occurs most often when users delete their user profile and restore a backup copy. This problem occurs because the pinned programs from the previously backed up User directory still exist, but they no longer appear on the "new" start menu after the backup is set in place. Whenever you see a "(2)" after a shortcut, it means it's a duplicate copy of an already existing shortcut, so you know that somewhere hidden in your computer, that shortcut already exists. You just need to find it and delete it.

You can fix this by going to the following (hidden) directory:

C:\Users\[YOURUSERNAME]\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\StartMenu

If you don't have "view hidden folders" enabled, enable it by going to folder options.

Once you're in that folder, you'll see that both your "new" pinned program with the "(2)" after it as well as your "old" pinned program (without the (2) on it) are both in that folder. Delete everything in that folder, unpin any programs you already have pinned to your start menu that have (2) on them, and then re-pin them. You should now have the programs pinned without any erroneous numbers attached to them.

share|improve this answer
add comment

The answer is indeed found in the C:\Users\(USERNAME)\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\Taskbar...

However I resolved the problem by checking the Properties of the icon in question (that even there wouldn't allow itself to be renamed). In my case, the icon was referencing an obsolete directory where I'd previously installed the application (Mozilla Firefox). For some reason that icon wasn't removed from my user profile and thus tainted every icon I tried to place on the taskbar. Once I changed the Target: and Start In: directories, the name of the icon changed without a hitch.

share|improve this answer
add comment

Right mouse click on the icon, go to properties. On the general tab in properties rename the application to something meaningful to you (renamed "Microsoft Access 2010 (5)" to "MS Access 2010"). That worked. Just removing the "(5)" gave me a dialogue that offered to create "Microsoft Access 2010 (6)" and advised me the name already existed!!

share|improve this answer
add comment

You could create a desktop icon, make sure that it's called what you want or change it to what you want. Then right click on the desktop icon and choose "pin to taskbar". Or drag it to the taskbar.

I suspect that when you create the desktop icon, it'll still be called "Shiretoko (64-bit) (2)". In that case it looks like you have two Shiretoko installations, or that the recent installation is named as such due to a leftover folder from a previous installation.

share|improve this answer
    
You are correct. Creating a shortcut and pinning it still appends the (2). I've uninstalled all Shiretoko (64-bit) installations and confirmed they've left no remnants in Program Files. –  Jason R. Coombs Oct 28 '09 at 12:27
    
In that case, maybe use Everything voidtools.com to do a thorough search for any remaining items anywhere. –  outsideblasts Oct 28 '09 at 18:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.