Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When trying to restore files using Windows 7 Backup & Restore, I get this error:

enter image description here

It doesn't appear to matter what backup date I try to restore from. I always get this message. Quick research takes me to lots of other people asking the same question, but it always boils down to using sdutil.zip to rebuild the MediaID.bin file. However, where the heck do I find this file?

At any rate, I don't trust any of what I've read from other internet threads regarding how to fix this. It's just the same copy pasta with the same people talking about how they're still having the issue. Therefore, I am trusting the gurus here at SE to actually deliver an experience-based solution. Keep in mind that experience-based refers to a solution that you yourself have actually come to by your own trial and error, a solution that you have actually used to solve this problem. I am trying to avoid any answers that involve Here, I Googled your problem and found this link. Give it a try.

If you can help me out, please do.

share|improve this question
    
1.st make backup of your current files then try this. => support.microsoft.com/kb/940263 (It refeers to vista but should work for windows 7.. | or do it manually => windows.microsoft.com/en-US/windows7/… –  Homer Simpsons Jul 6 '13 at 2:35
add comment

3 Answers

I cannot talk from personal experience, since I avoid the very buggy and fragile Windows Backup at all cost.

The best I can do is offer a link, that, ahh uhm.. , yes, I googled for :
Procedure to Rebuild MediaID.bin for Restoring Backups.

The blog contains a download link to a utility, but as this requires registration I didn't follow through.

The described procedure and utility are reported as working, although an additional advice was to run the command prompt as administrator and to use the root disk letter of the backup drive.

In the future, I suggest instead of Windows Backup to use a free utility such as AOMEI Backupper.

share|improve this answer
    
use a free utility such as AOMEI Backupper …the “More Easier Backupper”. –  Synetech Nov 30 '13 at 0:18
add comment

The answer to your question can be found here: http://answers.microsoft.com/en-us/windows/forum/windows_7-performance/getting-an-error-0x8100001a-while-trying-to/1472d543-eec2-4ccf-a2d1-c8b0019c1c8c?page=2

You must ensure that your backup volume letter matches the letter at creation of the backup. If you've not recorded this information you can use sdutil.exe which will fail but tell you the volume letter it is looking for.

share|improve this answer
    
That link suggests to change a whole drive letter? Am I reading that right? –  oscilatingcretin Nov 29 '13 at 5:52
add comment

harrymc's answer may be the best option, but I haven't tried it out due to the fact that, in my haste to restore the data in the backup, I've found a work-around that let me get by data back with a lot less steps. My approach doesn't repair a corrupted .bin file, though, so it will not be useful to anyone who wants to continue backing up their files to their current archive. For me, it was much easier to restore my files and just create a new backup job. I am sure most of my problems could be solved by not using Windows backup in the first place, but it's free, I already have it, and isn't that bad, so I'll continue to use it.

Here are the steps I took:

  1. Right-click my backup archive and select Open from the context menu
  2. Open the archive folder I want to restore from (Backup Set 2013-05-16 121237)
  3. Search for *.zip to display all zip files in the archive
  4. Lasso up all zips and extract them to another folder

So far, this was all I needed to do to get my files back in a pinch.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.