Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I get the same error as in this question: Error 0x800F0906 while installing .Net 3.5 on Windows 8

However the Surface Pro didn't come with installation media so I can't follow the offline installation as advised in the answer to that question.

Also not sure why this doesn't work, I can access the internet fine, can install updates OK, and can access www.update.microsoft.com.

share|improve this question
Are you trying this on a corporate network? If yes the 2nd point in the answer there is relevant: Your administrator has configured your computer to use Windows Server Update Services (WSUS) instead of Windows Update for servicing. Please ask your administrator to enable the policy to use Windows Update instead of WSUS. –  Chethan S. Jul 6 '13 at 4:27
Thanks but it's not a duplicate (that's the same question I linked to and the answer doesn't work unless you have an iso or installation media). And no I'm not on a corporate network I'm at home and I haven't done anything with WSUS, nor do I have an administrator. I need this to run Bloomberg which gives an error on installation if 3.5 SP 1 of .net framework is not installed. –  Simon D Jul 6 '13 at 4:33
Thanks, I have deleted that 'duplicate' comment (which came up once I raised the flag) and upvoted the question. –  Chethan S. Jul 6 '13 at 4:36
I've downloaded a 242,743,296 byte dotnetfx35.exe installer, this just brings up a window "An app on your PC needs the following Windows feature: .NET Framework 3.5 (includes .NET 2.0 and 3.0) / Install this Feature. When I click Install it says "Searching for required files" and a progress bar that loops without any progress. –  Simon D Jul 6 '13 at 5:05

1 Answer 1

up vote 3 down vote accepted

Download the 64Bit Windows 8 Enterprise Trial from here


mount this ISO and run the DISM command

Dism /online /enable-feature /featurename:NetFx3 /All /Source:x:\sources\sxs /LimitAccess
share|improve this answer
Awesome thanks! –  Simon D Jul 8 '13 at 12:27

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.