Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I use FF or Chrome to look at photos on Facebook, and save the photos to the hard drive, the photos will be saved as JPG, which is what the photo is originally.

But once in a while when IE 8 is used, the photo will be saved as BMP. (try the ones on Facebook, for example). Is there a way to make IE 8 (mine is on Win7) not save it as BMP and as JPG? thanks.

share|improve this question
    
Assuming the other answers are wrong, and this is not a configuration bug: I don't have this issue in IE 9. You should upgrade and see if that helps. Even if it doesn't, running the latest version will protect you from security and compatibility issues. –  Isaac Rabinovitch Nov 30 '12 at 21:50
    
The flippant answer would be to not use IE at all! –  Lee Taylor Dec 1 '12 at 0:14
add comment

4 Answers

up vote 5 down vote accepted

here's an MSKB artcicle dealing with the matter:

Internet Explorer saves images as bitmaps (.bmp Files)

and here's a possible solution for the problem with IE7/8

Tools > Internet Options > Advanced tab > Internet Explorer Settings

Click the Reset button

check the box Delete Personal Settings

Click Reset and restart IE.

share|improve this answer
    
Too bad, seems to apply to IE6 and earlier? Still, quite a funny cause: This behavior may occur if a damaged program file (for example, an ActiveX or Java object) is downloaded to the SystemRoot\Downloaded Program Files folder on your hard disk. –  Arjan Oct 27 '09 at 20:08
1  
i had the problem actually myself not too long ago, hell if remember how i fixed it :) –  Molly7244 Oct 27 '09 at 22:31
add comment

For me, this happens when your Temporary Internet Files gets filled up. So just remove/delete all the files in your Temporary Internet Files. I think there's a max limit to the size of this folder.

share|improve this answer
add comment

Go to Tools --> Internet Options

Under "Temporary Internet Files", click Delete Files.

Click OK.

Select the Settings button next to the Delete Files button

In the following Settings window click the View Objects button

Go to the Status column for the list of items. Check for any items marked Damaged Or Unknown and delete them by right clicking on them (in the Program file column) and select Remove.

Click Yes when asked whether you're sure.

Close the window. Click OK on the all remaining windows.

Now quit the program, restart it, and try saving an image.


I Hope This Helps...

share|improve this answer
add comment

This problem has been with Internet Explorer since Windows 95.

I use a simple workaround:

  • Right-click on the image
  • Select Email Picture

    When Outlook comes up with the image attached (as a .JPG file like it is supposed to be)

  • Right-click on the attachment
  • Select Save as
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.