Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've bought a laptop which came pre-installed with Windows8 (UEFI enabled). I've read in many places that if I install Linux alongside it, I could run my Windows8 virtualized (instead of using dual boot which is less ideal), setting it up in one of these two possible methods:

  1. Convert the physical OS to virtual.
  2. Run the virtual machine using the physical disk (only the Windows8 partitions obviously).

I've tried both and I haven't been able to make it work. Below are the explanation of all the problems I ran into:

  1. Used VMWare Converter to create a virtual image (I did this before installing Ubuntu). This created two VMDK files and a VMX one. After this I installed Ubuntu (I had to disable UEFI in the BIOS for this). Then I tried to run this image first with VirtualBox, and it doesn't work (tried with both VMDK files, and with only one; tried also enabling/disabling the EFI option), it hangs with 100% CPU for minutes until I give up (about 10 minutes). Then I downloaded VMWare Player 5.x and tried with it as well, and it crashes when I try to run the virtual image (tried to obtain an error message by running it from the console, to no avail).

  2. Used sudo VBoxManage internalcommands createrawvmdk -filename /home/knocte/Documents/VMs/win8phys/win8phys.vmdk -rawdisk /dev/sda -partitions 2,4 -relative to create the virtual machine that runs with physical disks. Had to run chown myuser:myuser /dev/sda2 /dev/sda4 before launching the image. The result: it also hangs.

I'm wary of the fact that UEFI is a new thing and I've read in some places that VirtualBox developers still are working to improve things in this side, and current support could be kind of experimental. But this Ubuntu 13.04 brings VirtualBox 4.2.10_Ubuntu r84101, the last version is 4.2.16, and the changelog between them doesn't mention UEFI fixes or improvements at all.

Also, this laptop comes with two hard disks: the first is a normal 700 GB one, and the second is a 16 GB SSD which works as a "cache" to the first one, as advertised. I'm guessing this cache-handling is done via software, because I can also see the SSD disk from Linux (it's /dev/sdb). So I'm wondering if my problems come from the fact that I'm not including this disk when I've tried to virtualize the Windows8. The thing is GParted doesn't give much clues about this disk:

cache SSD disk in gparted

And for completeness, this is what GParted sees about the main disk (after Linux was installed):

main disk in gparted

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.