Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This has been bugging me for a while, and apologies for poorly constructed title, but it seems like Google Chrome and Safari are the same thing on OS X.

I use Chrome exclusively on OS X Mountain Lion running on a MacBook Pro.

Occasionally, sites will be broken in that some functionality is not working correctly (e.g. video not playing on a ultra popular sites that I'm pretty sure are not just globally broken). In those cases I'll fire Safari to see if this is an issue with Chrome. I've tried this in 20 or so cases, but the behavior in Safari is always 100% identical.

Every single little issue I'm experiencing on Chrome will be exactly the same on Safari. As if it's the same browser with a different shell around it. In the past I've done web development for nearly a decade and knowing how sensitive some things are between browsers – it's just hard to believe that there's never been a different behavior and all the same things are broken on Safari.

update

i forgot to mention i've also been checking using Firefox.

other examples are links not working. for example on nieman marcus i can load initial search, but none of the links work on chrome/safari (such as "next" or "120")

however in this particular example firefox works.. so it indeed could be webkit related. has anyone had similar experience?

share|improve this question
1  
WebKit. –  Arjan Jul 6 '13 at 16:14
    
Is it really just video not playing? I find it hard to believe you're seeing so many bugs… can you add more examples? –  slhck Jul 6 '13 at 16:37
    
Have you disabled Javascript, Flash, or cookies? Those links work for me if Javascript is on, but do nothing if it is off. –  mark4o Jul 6 '13 at 19:55
    
@mark4o if i disabled any of those that would be a clear reason why it didn't work :) –  Sonic Soul Jul 7 '13 at 1:43
add comment

1 Answer 1

up vote 1 down vote accepted

The rendering engine for both Chrome and Safari is based on WebKit, so there will be many similarities. (Chrome is switching to their own Blink rendering engine, but it is still a fork of WebKit.) Try Firefox if you want to check another rending engine (Gecko).

The content may rely on plugins such as Flash, Java, or QuickTime, and so may be using the same code in different browsers. Ensure that your plugins are up to date.

You may have a machine-specific issue such as a graphics card with broken drivers. Try a different machine with different hardware to rule that out.

You may also have an issue with a proxy or caching server, a firewall, or filtering software, which may affect your entire network. Try a different network, e.g. using a VPN, work network, or wifi at an Internet cafe.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.