Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Windows 7. When I plug in the network cable the internet works fast, but when I use WiFi it's extremely slow.

Please help me fix this problem and also mention if the problem is with my WiFi device or with Windows itself (or other software).

share|improve this question
    
I'm curious whether your problem is latency or throughput. Using Wifi, please open a command prompt, then execute route print. Under IPv4 Active Routes, find the entry for destination 0.0.0.0 netmask 0.0.0.0 (the default route) and look at the gateway IP address (third field on the line). Then ping -n 2000 a.b.c.d, replacing a.b.c.d with your gateway address. It'll take a while but runs fine in the background. When it finishes, edit your post and add the summary printed at the bottom (the four lines about ping statistics and round trip times). –  Michael Kjörling Jul 7 '13 at 8:04
    
Also, log into your router or access point and look at wireless networking statistics or whatever it's called on your particular hardware. See if it reports packet counts, collision statistics or anything along those lines. If it does, please edit those numbers as well into your post. If there are other networks on the same radio channel as you are using, that will cause collisions (and require retransmission), which can greatly reduce the useful data transfer rate that you experience. –  Michael Kjörling Jul 7 '13 at 8:11
1  
This question doesn't really have an answer. You've just discovered the blindingly obvious: like-for-like, wireless is almost always slower than wired. The problem is not with Windows, it's your Wifi router. There's not much you can do to improve the router's performance, although your router may have a few settings you could experiment with. Time to buy a new one. –  Pete855217 Jul 7 '13 at 8:15
    
What is the brand of your router? –  Young Pizza Jul 7 '13 at 20:02
    
Could you please include the brand and type of wireless router you have, if it's a combo router (many ISPs like to do that these days), how long you've had it, the temperature of where you live, and possible speeds. All of this can help to at least diagnose if it's a software or hardware problem. The other thing is that this may be beyond your control: when you have high humidity levels in the summer it can interfere with the wireless signal. I've also found my own ISP to be less reliable in the summer when energy demands are higher. –  redknightalex Jul 8 '13 at 3:24

4 Answers 4

Many possibilities exists.

What type of Wifi are you using 802.11 a/b/g/n or etc If you got "a" there is your problem right there.

How strong does Windows report the signal strength? If the distance is <10ft as mentioned you should have full bars.

How many other wifi networks exist that overlap yours? If another wifi router device is using the same channel as yours they will fight each other. Depending on how close the other wifi router is it will reduce your reception quality significantly.

You could be using a USB wifi adapter. If the usb port were 1.0 or 1.1 or running at that version of usb there is your problem.

You wifi router could be malfunctioning. How old is it? Has the firmware been upgraded?

Go to the store with a friendly return policy buy a new one try it for a day and if it sucks also take it back for a refund. If the new one is awesome problem solved.

share|improve this answer

Wi-Fi is always slower then a wired connection.. ok, not always, but with all current networking, it is.

Wireless has a certain maximum speed, under perfect conditions, including no interference, no other radios in the area, the Wi-Fi antennas are next to each other, and no one else is connected to it. So does your wireless meet all those rules so it can run at 150mbps?Or would the reliable wire running at 1000mbps be faster?

share|improve this answer
    
Dear, I am using it in my room so hardly a distance of 6 to 7 ft, No one is using it as I have protected it with password. I know it is slower than wired network but it was working fine earlier... –  Moeed Farooqui Jul 7 '13 at 7:48
1  
Wi-Fi routers also die, as do all equipment eventually. That is a sign of aging. Try updating the firmware, but for 6 ft, plug in and forget it –  Canadian Luke Jul 7 '13 at 7:50
    
Oh man that was just for the example what If I want to sit 7 ft or 8 ft... so You are trying to say my WI-FI would be no more in coming days :'( –  Moeed Farooqui Jul 7 '13 at 7:53
    
I doubt I'd call even slow WiFi "extremely slow". A few tens of megabits per second is still plenty more than a lot of people have downstream even these days. I'm guessing that the problem is latency, possibly introduced by radio channel congestion if the OP is the only one using the intended wireless network. If so, moving the network to another channel might help. –  Michael Kjörling Jul 7 '13 at 8:09

This is probably not a software or hardware fault. Your problem occurs probably because other people use the WiFi simultaneously when you do, decreasing your connection speed. If you are certain nobody uses the WiFi in the time you do, consider these steps:

  • Change the WiFi password (or set up a password if you don't have one) to something which isn't your date of birth, telephone number, etc - these are very easy to guess.
  • If possible change the encryption to any kind of WPA (preferably WPA2-PSK), it is harder to crack then WEP.

Update all drivers and the router's firmware.

Also note that essentially WiFi (or other types of wireless networking) are generally slower then cable because:

  • Stuff can interfere with the signal (other antennas, thick walls, etc)
  • WiFi has typically lower speed limit then cable
  • Sometime even the weather conditions effect the signal
  • And other reasons
share|improve this answer
    
Dear, I am using it in my room so hardly a distance of 6 to 7 ft, No one is using it as I have protected it with password. I know it is slower than wired network but it was working fine earlier... –  Moeed Farooqui Jul 7 '13 at 7:49
    
Ok, update all the drivers. Like 80% of software issues are because of drivers. –  matan129 Jul 7 '13 at 7:50
    
How about re-installation of Windows? –  Moeed Farooqui Jul 7 '13 at 7:51
    
No need, it can't be the reason (unless it's super rare extreme condition that nobody heard of it before). Just update the drivers. –  matan129 Jul 7 '13 at 7:53
2  
Or blown speakers. Save that for another question –  Canadian Luke Jul 7 '13 at 13:43

If you don't mind installing 3rd party software, install inSSIDer.

Open it and change your tab to 2.4GHz or 5GHz channel depending on your signal. Your wifi signal should be floating somewhere on the graph.

Next, you need to open your router's page. If you don't know the ip, Open command prompt and type in "ipconfig".

Copy the ip address under "Default Gateway".

Open your favorite web browser.

Paste the IP address to the URL bar.

Enter any relevant username/passwords for that router. This is different from the password for connecting to the wifi.

Depending on the UI, search for an option to change the channel. It should be somewhere like "wireless settings" or something like that.

Back to inSSIDer, determine which channel that have lots of wifi.

Back to the router page, change your channel to a less crowded channel.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.