Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My friend bought a Gigabyte motherboard for use in a hackintosh and for some reason it does not detect the keyboard. The keyboard lights up but no input is detected. He can not access the BIOS and has tried many things such as:

  • Clearing the CMOS
  • Removing all unnecessary components
  • Using a different keyboard
  • Using a USB to PS/2 adapter
  • Using different USB ports

Right now I do not have the exact model but I know that it is a Socket 2011. I will find out the model and update my post.

UPDATE #1______________________________________________

Ok i'm going to clear up some things

THERE IS NO OS INSTALLED ON THE PC!

When it boots this happens:

  1. POWER BUTTON PRESSED
  2. SYSTEM BEEPS ONCE
  3. BIOS SPLASH SCREEN SHOWS
  4. CANNOT ACCESS BIOS AS KEYBOARD DOESN'T WORK
share|improve this question
    
Try a PS2 keyboard, USB keyboards can be disabled in BIOS. –  gronostaj Jul 7 '13 at 12:59
    
well they tried a usb to ps/2 adapter, wouldn't that be the same? –  olafgarten Jul 7 '13 at 13:04
    
Start with some basic testing: 1) Does the keyboard work in another computer. What happens with a different keyboard? (E.g. is the keyboard itself fine or broken?). 2) You write he tried different USB ports. Did he also try both USB2 and USB3 ports? (if not try an USB 2 port! 3) While any PS/2 keyboard should just work, some BIOS's are fiddle and need legacy USB support set to enabled in the BIOS. (Note that even without this the BIOS should work, but sometimes a BIOS does unexpected things.) –  Hennes Jul 7 '13 at 13:06
1  
Assuming that the active USB to PS/2 adapter works: Yes, it should be the same. If you just used a passive plug like this one then you need support from the keyboard. (Basically the keyboard needs to support both USB and PS2 and will switch modes when it detects such a plug. If it does not you will need an active converter, like this one. –  Hennes Jul 7 '13 at 13:09
1  
Do the keyboard LEDs flash momentarily during the power-on self test, or could the keyboard just as well not be connected at all? –  Michael Kjörling Jul 7 '13 at 13:15

1 Answer 1

I found this post because I too have a Gigabyte motherboard (ga-m59sli-s4) in my desktop PC and was unable to change the boot order and launch a linux live distro.

However, I SOLVED my problem!

I was able to use USB-keyboard in the BIOS setup but most options were locked and couldn't be changed (including "USB Keyboard support" which was disabled). The solution was simply to put the keyboard in a different USB-port on the back of the computer; front panel ports didn't work. Assuming you're looking straight at the back of the computer with the motherboard fitted vertically to the left side of the tower, it's the top right USB-port in my case but try them all. Doing this not only unlocked the "USB keyboard support"-option but also enabled all other options in the bios (e.g. set supervisor password, adjust CPU clock speed, temperature control etc.)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.