Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

What could cause an import to Gmail in Thunderbird to exclude many (i.e., more than 1000 emails not copied in a folder with 1284 emails) that were in the original account?

I am imagining things like spam filters in either Thunderbird or Gmail, or an overly intrusive anti-virus, or something which interrupts the Thunderbird process before it completes.


I am using Thunderbird to import several thousand emails that are grouped into around 40 different folders into Gmail. There were originally stored locally in Outlook Express, and after successfully importing those into Thunderbird I added Gmail to Thunderbird as an IMAP account, and have begun the task of copying folders over. (This is the process recommended by every guide to getting emails out of Outlook Express and into Gmail that I have read.)

Unfortunately when I copy a folder, some will not copy... in a non-deterministic way. For instance in one folder I get 467 out of 477 emails. In another with 1000+ emails, only 84 copy, or 53 the next time, or 128 the third time. I've worked out that duplicate emails (exact subject, body and time match) aren't being copied, but this only accounts for say 10 of the 1000+ email folder. I also get different results when I copy a folder vs. when I create the corresponding Gmail label myself and select all emails in the original folder and copy them into the new label.

With most of the folders I get a message saying:

Copied 574 emails from 'chicken soup' to 'chicken soup'

in the Thunderbird activity manager, but only 80 messages actually appear under the Gmail label. Occasionally (one in ten folders perhaps) the activity manager says:

The current command did not succeed. The mail server for account responded: Invalid Arguments: Unable to parse message

But again, the absence of an error message seems to have no bearing on whether everything copied correctly.

share|improve this question

1 Answer 1

Go: Edit -> Account Settings -> Synchronization and Storage, be sure that "Synchronize all messages regardless of age" is checked. Also go in "Advanced" tab and be sure that thunderbird is subscribed to all your imap folders.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.