Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Some time ago I experimented with the relativenumber setting. It almost never turned on, so I finally gave up and took it out of my .vimrc. Now it seems that every time I open up a new instance, I start out in relativenumber mode, and my .vimrc settings have no effect. Where is MacVim storing this setting and how can I change it?

share|improve this question
    
Post your vimrc... and gvimrc –  FDinoff Jul 7 '13 at 17:32
    
Also did you really mean to type .virmrc settings? Its .vimrc –  FDinoff Jul 7 '13 at 18:35
    
Your settings are supposed to be in ~/.vimrc, is that the correct file? Also, do you use sessions? Tinkering and using sessions can create all sorts of confusing issues. –  romainl Jul 9 '13 at 7:07
    
@FDinoff it was in .gvimrc - I'll accept your answer if you post one. –  Justin Love Jul 9 '13 at 13:23
add comment

2 Answers

up vote 0 down vote accepted

MacVim will check two main locations for settings. ~/.vimrc and ~/.gvmirc make sure

set relativenumber

and

set rnu

are not in either of these files.

Also vimrc is sourced before gvimrc so settings in gvimrc will override settings in your vimrc.

share|improve this answer
add comment

The setting was in my forgotten .gvimrc.

share|improve this answer
    
even though this is you own question, make your answer more descriptive to help others who might face similar situations –  Shakehar Jul 9 '13 at 14:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.